[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Can't get Dom0 PV_OPS working properly

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Ian Murray <murrayie@xxxxxxxxxxx>
  • Date: Thu, 13 Jan 2011 15:05:11 +0000 (GMT)
  • Delivery-date: Thu, 13 Jan 2011 07:06:30 -0800
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.co.uk; h=Message-ID:X-YMail-OSG:Received:X-Mailer:References:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=ojEE/HpCyhfVywOy7+63V2nJZTBMTZrZW1tbLB4v3tZO/7lNw1sL4xiUDF1X9ashfAH/iqBITWrcU3T1kPxYyEkXrQf5+STVWtGuPUT9y2iIPDbH09OgIE439WxphskIuZXgDBWmmT1tcQi6BmAvTG61WmG7ImsGA80LFk5HQbI=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

----- Original Message ----
> From: Sergey Tovpeko <tsv.devel@xxxxxxxxx>
> To: Ian Murray <murrayie@xxxxxxxxxxx>
> Cc: xen-users@xxxxxxxxxxxxxxxxxxx
> Sent: Thu, 13 January, 2011 13:14:27
> Subject: Re: [Xen-users] Can't get Dom0 PV_OPS working properly
> > I had a reliable system running Xen 3.4.3 (GitCo)  using the  CentOS Xen 
>kernel (5.5). I wanted to do some PCI passthrough but I got an issue  with 
>(or similar). Google told me that that I had to use the Xen 2.6.18 or  PV_Ops 
> > I downloaded the "Jeremy" PV_OPS kernel and compiled it  okay, having 
>followed the Wiki entry instructions (I think!). I read somewhere  that I 
> > should go to 4.0.1 Xen, which I did. The kernel runs fine as a  standalone 
> > and boots under Xen.
> > 
> > I am having the  the following issues:-
> > 
> > * I can't get any screen console output  (despite console=hvc0 at the dom0 
> > line)
> > 
> > * PV  VM's fail to start properly. As soon as they start, they sit at 100% 
>CPU  according to xm top and don't progress. A Windows HVM guest appears to 
>start  okay. I haven't tried any other HVM. I have tried PV guests based on 
>CentOS  kernel and Ubuntu 10.10 PV_OPS, which do the same.
> > 
> > I tried to  look at the various logs but I don't see anything that gives me 
> > a 
>clue, but I am  not Xen expert to know what I am looking for.
> > 
> > When I revert  back to 4.0.1 + CentOS's Xen kernel as Dom0, all VM's start 
>and operate  properly.
> > 
> > Any advice is much appreciated.
> > 
> >  Thanks in advance,
> > 
> > Ian.
> >  
> Hello,  Ian!
> As I understood correctly your main point is to have the ability to  use  PCI 
> It appears to be a problem in Jeremy's pv_ops  kernel as Dom0 to run PV 
>domains. I could propose you to try 2.6.18 Dom0 if it  only suits for you.
> http://xenbits.xensource.com/linux-2.6.18-xen.hg
> To download it you  can use Mercurial tool with
> hg clone http://xenbits.xensource.com/linux-2.6.18-xen.hg

Hi, thanks for the response!

I was considering that but I was worried about the drivers being old. The 
works fine with CentOS but I think I am relying on a back-ported driver 

are we saying that there are known issues around running PV VM's and the PV_OPS 

Thanks again,


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.