[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Can't find root when start vm

Le 10/02/2011 16:06, Jose Legido a écrit :

On 10/02/11 12:18, Erwan RENIER wrote:
Le 10/02/2011 11:35, Jose Legido a écrit :

On 10/02/11 11:13, James Harper wrote:
I can't start Virtual Machine, have the message:
   Waiting for root file system ... done.
Gave up waiting for root device.  Common problems
ALERT!  /dev/xvda2 does not exist.  Dropping to a shell!

I have installed Xen 4 in a debian squeeze:
# uname -a
2.6.32-5-xen-amd64 #1 SMP Wed Jan 12 05:46:49 UTC 2011 x86_64
xen-hypervisor-4.0-amd64                4.0.1-2
Xen Hypervisor on AMD64

I have created the virtual machine with this command:
# xen-create-image --size=2Gb --swap=128Mb --dhcp --dist=stable
--dir=/home/xen --hostname=debian

My debian.cfg is:
kernel      = '/boot/vmlinuz-2.6.32-5-xen-amd64'
ramdisk     = '/boot/initrd.img-2.6.32-5-xen-amd64'
vcpus       = '1'
memory      = '128'
root        = '/dev/xvda2 ro'
disk        = [
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

In my Server the filesystem is /dev/sda1.
I have tried with:
root        = '/dev/xvda1 ro'
root        = '/dev/sda1 ro'
root        = '/dev/sda2 ro'

And the same problem

In the /dev vm I have:
(initramfs) ls /dev
char console core cpu_dma_latency fd full hvc0 hvc1 hvc2 hvc3 hvc4
hvc6 hvc7 input kmsg mapper mem network_latency network_throughput
port psaux ptmx pts random snapshot ttyx urandom vcs vcs1 vcsa vcsa1
vga_arbiter xen zero

I have tried with vcs vcs1 vcsa vcsa1 but have the error:
mount: mounting /dev/vcs1 on /root failed: No such file or directory

Any idea? I'm making wrong something?

A lot of thanks!

Does /dev/xvda1 exist?
No, only vcs, vcsa and sda
Is the frontend block device driver compiled as a
I have installed xen from aptitude install. I didn't configured frontend
block device driver, should I?
Xen-users mailing list

Hi , what's in the log of the vm ( like
/var/log/xen/qemu-dm-debian.log ) ?
And in the xend.log ?

Hello, I can't see nothing in the logs. I upload in ompldr.org:


it indeed create your disks as vcsa1 and vsca2 :

 createDevice: vbd : {'uuid': 'c5fb4564-05e6-8323-97f6-1ecbc43ab0f8', 
'bootable': 1, 'driver': 'paravirtualised', 'dev': 'vcsa1', 'uname': 
'file:/home/xen/domains/debian2/disk.img', 'mode': 'w'}

Here's one of mine :

createDevice: vbd : {'uuid': 'feaa1b2d-3017-e010-ec5d-2a612826e5bd', 'bootable': 0, 'driver': 'paravirtualised', 'dev': 'xvdb1', 'uname': 'phy:vg0/erp5', 'mode': 'w'}

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.