[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] HVM domU doesnt start

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Alberto Asuero Arroyo <albertoasuero@xxxxxxxxx>
  • Date: Tue, 15 Feb 2011 08:57:31 +0100
  • Delivery-date: Tue, 15 Feb 2011 00:00:32 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:from:date:message-id:subject:to:content-type; b=sqYrLv+HCZPtdCbuLKxRf+SfFEDjKwe53A/mUCXLPhkRAUdheetBi7VkpBT1quOC8+ vQFG70gQjczz15JOCL6VLnz9kLJ/KwYlZJcFxWj8QUujxWKQN5ToVJ5/YcfCuvS8jPto DgKVnRhOiQM68NOUcOmRyPOf0ML+ICww6Fe7U=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I've a ubuntu server running over a HVM DomU. After a hang, the domU doesn't start again.

The domU was not able to mount the virtual machine disk so I started with a live cd and I tried to mount the disk root part / with no success so I ran  fsck.ext3 and it gave me input/output error in the domU and in dom0 the kernel says:

Feb 14 18:22:28 scofield last message repeated 5 times
Feb 14 18:22:30 scofield kernel: sd 0:2:3:0: [sdd] Unhandled error code
Feb 14 18:22:30 scofield kernel: sd 0:2:3:0: [sdd] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
Feb 14 18:22:30 scofield kernel: end_request: I/O error, dev sdd, sector 1073919
Feb 14 18:22:30 scofield Server Administrator: Storage Service EventID: 2095  SCSI sense data Sense key:  3 Sense code: 11 Sense qualifier:  0:  Physical Disk 0:0:3 Controller 0, Connector 0

Other important think was that in domU with live CD I could mount other partitions of the disk with no errors but not the root partition.

The first think I thought it was a hard disk problem, so I tried to copy the img to another hard disk in my dom0 but input /output erros was reported. After that I've reinstalled the machine on the same hard disk and it works perfectly.

How is it possible? Could a corrupt image make impossible copy it? I've had this problem twice and I've to reinstalled the machine.

Maybe I'm doing something wrong create the image with dd. I use the following command for a image of 900GB

dd if=/dev/zero of=file900G.img bs=1M count=921600

I cant remember very well, but I think the issue is because I created a image with dd bigger than hard disk size, If I do it dd command doesnt says nothing, let's to see that.

# df -h                 
                           Size    Used  Avail   Use     Mounted on

/dev/sdd1             917G  1,7G  869G   1%      /vserver/images/domains/mahone

Let's create a image of 900GB it should be report errors but NO errors are reported!!

# dd if=/dev/zero of=/vserver/images/domains/mahone/mahone.img bs=1M count=921600
921600+0 records in
921600+0 records out
966367641600 bytes (966 GB) copied, 26901,7 s, 35,9 MB/s

# df -h
                           Size    Used  Avail   Use       Mounted on

/dev/sdd1             917G  902G     0      100%    /vserver/images/domains/mahone

Thanks in advance

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.