[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: 3.0.0-rc2: Xen: QEMU Kernel panic - not syncing: IO-APIC + timer doesn't work!

On Mon, Jun 13, 2011 at 02:38:25PM -0400, Konrad Rzeszutek Wilk wrote:
> On Mon, Jun 13, 2011 at 07:35:32PM +0200, Tobias Diedrich wrote:
> > Hi,
> > 
> > I ran into this problem when trying to set up Xen on a root server
> > with a pre-Orleans Athlon64 (no svm, so no kvm):
> Uhh, your output says otherwise. What is the serial output your
> box produced?
> > 
> > Since 3.0-rc is supposed to have Xen DOM0 support I of course want
> > to use this rather than some old xenified kernel version. :)
> > 
> Ok.
> > I later got it to boot using "noapic apci=off" (just noapic wasn't
> > sufficient, I had to add acpi=off because it had interrupt routing
> > problems with just noapic), and I can see that the APIC handlers in
> > arch/x86/xen/enlighten.c are just stubs so far.
> Right.
> > 
> > So is this supposed to work with APICs?
> Yes. Well, it actually should just bypass/ignore the APIC calls and
> the warnings are suppose to be benign.
> But somehow your environment triggered a weird state. I've to admint
> I hadn't tried to boot Xen + paravirt Linux under QEMU for some time.

Just tried (but didn't do it with KVM, just normal QEMU without KVM or Xen)
and I was able to reproduce the issue you saw. Thought it looks like as if
my default .config does not cause this issue.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.