[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] How to configure vif in Xen?

   I built Xen-4.2-unstable and kernel- on CentOS 5.5 successfully! I also implemented fault tolerance and high avaliability via remus under your advices!
   Thank you very much!
   But I got new problems:
  1. The vif of VM didn't work, when I start a new VM by command: "xm cr myvm.hvm", system returned message: "the <VM> does not exist".
     my VM's configuration file is:
   ernel = "hvmloader"
   memory = 512
   name = "myvm"
   vif = [ 'type=ioemu, bridge=eth0,mac=00:16:3e:3a:7a:dd' ]
   pae = 1
   acpi = 1
   apic = 1
   #disk = [ 'file:/home/xen/tpl/hvm/base.img,hda,w', 'file:/home/xen/tpl/hvm/CentOS-5.5-x86_64-bin-DVD-1of2.iso,hdc:cdrom,r' ]
   disk = [ 'file:/home/xen/tpl/hvm/win.img,hda,w', 'file:/home/xen/tpl/hvm/windows-XP.iso,hdc:cdrom,r' ]
&n! bsp;  device_model = 'qemu-dm'
   sdl = 0
   vnc = 1
   vnclisten = ""
   stdvga = 0
   serial = "pty"

     if I deleted the "vif = [ 'type=ioemu, bridge=eth0,mac=00:16:3e:3a:7a:dd' ]" , the vm started successfully, but the VM could not access network.
     I have installed the bridge-utilty package properly.
     I checked the /val/log/message, it showed:
   Jul 29 04:04:34vnix06 kernel: [  205.540203] device vif1.0 entered promiscuous mode
   Jul 29 04:04:34 vnix06 kernel: [  205.545969] eth0: port 2(vif1.0) entering forwarding state
   Jul 29 04:04:34 vnix06 kernel: [  205.811565] eth0: port 2(vif1.0) entering disabled state
   Jul 29 04:04:34 vnix06 kernel: [  205.818948] device vif1.0 left promiscuous mode
   Jul 29 04:04:34 vnix06 kernel: [  205.818955] eth0: port 2(vif1.0) entering disabled state   Jul 29 04:04:35 vnix06 logger: /etc/xen/scripts/block: Path closed or removed during hotplug add: backend/vbd/1/5632 state: 6
   Jul 29 04:04:35 vnix06 logger: /etc/xen/scripts/block: xenstore-read backend/vbd/1/5632/node failed.
   Jul 29 04:04:35 vnix06 logger: /etc/xen/scripts/block: /etc/xen/scripts/block failed; error detected.
    could you tell me how to address this problem?
2. The NFS worked well in CentOS5.5, but when I compiled kernel-2.6.32-40 and Xen-4.2-unstable and got into dom0.
   the NFS didn't work, and could not mount the remote NFS server
. I tried command: "service nfs restart", but the failed.
   I used command: "mount <IP>:/home /mnt", the system returned:
   mount <IP>/home /mnt
  ! mount.nfs: No such device
 &n! bsp; wha t's wrong?
   I am waiting for your help! thank you very much!
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.