[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] How to configure vif in Xen?

  • To: "'Tiantian Liu'" <tiantianl@xxxxxxxxx>, <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Walter Robert Ditzler" <ditwal001@xxxxxxxxx>
  • Date: Tue, 2 Aug 2011 17:45:57 +0200
  • Cc:
  • Delivery-date: Tue, 02 Aug 2011 08:47:18 -0700
  • Importance: High
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AQJUDDMqiLrB/s5zpO47/WTBfqX9ZJP6OVRw

hi tiantian,


i think i wrote you that already, but i had several problems with defining the bridge network onto the dom0. and I also believe it is much faster to define it directly onto the network stack. so I did then:


the [/etc/network/interfaces] script:


auto lo

iface lo inet loopback


auto br0

iface br0 inet static






        bridge_ports    eth0

        bridge_stp      on

        bridge_maxwait  0


auto eth1

iface eth1 inet static







and at the domU script:


vif             = [ 'bridge=br0,mac=xx:xx:xx:xx:xx:xx' ]



the [/etc/xen/xend-config.sxp] script:


(network-script 'network-bridge antispoof=yes')

(vif-script vif-bridge)



the [/etc/sysctl.conf] script to activate routing on startup:


kernel.domainname                       = local.net

#kernel.printk                          = 3 4 1 3

#net.ipv4.conf.default.rp_filter        = 1

#net.ipv4.conf.all.rp_filter            = 1

#net.ipv4.tcp_syncookies                = 1

net.ipv4.ip_forward                     = 1

net.ipv6.conf.all.forwarding            = 1

#net.ipv4.conf.all.accept_redirects     = 0

#net.ipv6.conf.all.accept_redirects     = 0

#net.ipv4.conf.all.send_redirects       = 0

#net.ipv4.conf.all.accept_source_route  = 0

#net.ipv6.conf.all.accept_source_route  = 0

#net.ipv4.conf.all.log_martians         = 1




about your point 2), if there is no network, there is also no NFS (Network! File System) J



and my last point is, I always had serious problems with IOEMU. I don’t know if it is linked with my 1 year old hardware or if it is just too buggy. I left it everywhere away and it works for my J


thanks walter





From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Tiantian Liu
Sent: Dienstag, 2. August 2011 15:50
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] How to configure vif in Xen?


   I built Xen-4.2-unstable and kernel- on CentOS 5.5 successfully! I also implemented fault tolerance and high avaliability via remus under your advices!
   Thank you very much!
   But I got new problems:
  1. The vif of VM didn't work, when I start a new VM by command: "xm cr myvm.hvm", system returned message: "the <VM> does not exist".
     my VM's configuration file is:
   ernel = "hvmloader"
   memory = 512
   name = "myvm"
   vif = [ 'type=ioemu, bridge=eth0,mac=00:16:3e:3a:7a:dd' ]
   pae = 1
   acpi = 1
   apic = 1
   #disk = [ 'file:/home/xen/tpl/hvm/base.img,hda,w', 'file:/home/xen/tpl/hvm/CentOS-5.5-x86_64-bin-DVD-1of2.iso,hdc:cdrom,r' ]
   disk = [ 'file:/home/xen/tpl/hvm/win.img,hda,w', 'file:/home/xen/tpl/hvm/windows-XP.iso,hdc:cdrom,r' ]
&n! bsp;  device_model = 'qemu-dm'
   sdl = 0
   vnc = 1
   vnclisten = ""
   stdvga = 0
   serial = "pty"

     if I deleted the "vif = [ 'type=ioemu, bridge=eth0,mac=00:16:3e:3a:7a:dd' ]" , the vm started successfully, but the VM could not access network.
     I have installed the bridge-utilty package properly.
     I checked the /val/log/message, it showed:
   Jul 29 04:04:34vnix06 kernel: [  205.540203] device vif1.0 entered promiscuous mode
   Jul 29 04:04:34 vnix06 kernel: [  205.545969] eth0: port 2(vif1.0) entering forwarding state
   Jul 29 04:04:34 vnix06 kernel: [  205.811565] eth0: port 2(vif1.0) entering disabled state
   Jul 29 04:04:34 vnix06 kernel: [  205.818948] device vif1.0 left promiscuous mode
   Jul 29 04:04:34 vnix06 kernel: [  205.818955] eth0: port 2(vif1.0) entering disabled state   Jul 29 04:04:35 vnix06 logger: /etc/xen/scripts/block: Path closed or removed during hotplug add: backend/vbd/1/5632 state: 6
   Jul 29 04:04:35 vnix06 logger: /etc/xen/scripts/block: xenstore-read backend/vbd/1/5632/node failed.
   Jul 29 04:04:35 vnix06 logger: /etc/xen/scripts/block: /etc/xen/scripts/block failed; error detected.
    could you tell me how to address this problem?
2. The NFS worked well in CentOS5.5, but when I compiled kernel-2.6.32-40 and Xen-4.2-unstable and got into dom0.
   the NFS didn't work, and could not mount the remote NFS server
. I tried command: "service nfs restart", but the failed.
   I used command: "mount <IP>:/home /mnt", the system returned:
   mount <IP>/home /mnt
  ! mount.nfs: No such device
 &n! bsp; wha t's wrong?
   I am waiting for your help! thank you very much!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.