[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Kernel 3.1.0-rc2 hangs on boot, Xen 4.1.1

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Milan Holzäpfel <listen@xxxxxxxx>
  • Date: Mon, 15 Aug 2011 13:48:45 +0200
  • Delivery-date: Mon, 15 Aug 2011 04:51:41 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I tried out kernel 3.1.0-rc2 on my i386 Laptop with Xen 4.1.1.  Booting
hangs after these messages on the VGA console:

pci 0000:02:09.0: address space collision: [mem 0x000da000-0x000dafff] 
conflicts with reserved [mem 0x0009f800-0x000fffff]
reserve RAM buffer: 00000000 0009f000 - 00000000 0009ffff
reserve RAM buffer: 00000000 38400000 - 00000000 3bffffff
reserve RAM buffer: 00000001 07290000 - 00000001 07ffffff

The cursor hangs on the last line of this output.  I inserted some
space in the long memory address of the last three lines.  Is this
information of any use to Xen developers? 

I believe that Ubuntu Oneiric's 3.0.0 kernel has the same problem, but
I cannot verify this, because VGA output is broken and the Laptop
doesn't have a serial port.

I also tried out from
git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git (branch
xen/stable-2.6.32.x).  This kernel boots fine under Xen, but it does
not boot on bare metal.

I've attached kernel .config and dmesgs for the combinations that did


Attachment: config-
Description: Text Data

Attachment: config-3.1.0-rc2
Description: Text Data

Attachment: dmesg-2.6.32-xen
Description: Text document

Attachment: dmesg-3.1.0-rc2-bare-metal
Description: Text document

Attachment: xl-dmesg-2.6.32
Description: Text document

Attachment: xl-info-2.6.32
Description: Text document

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.