[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Kernel 3.1.0-rc2 hangs on boot, Xen 4.1.1

  • To: xen-users@xxxxxxxxxxxxxxxxxxx, Milan Holzäpfel <listen@xxxxxxxx>
  • From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
  • Date: Mon, 15 Aug 2011 05:29:46 -0700 (PDT)
  • Cc:
  • Delivery-date: Mon, 15 Aug 2011 05:31:08 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=X-YMail-OSG:Received:X-Mailer:Message-ID:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=bQopsOjsEmH/gQrfmJBq0vHM+hg/r86/fgnysyLnyUnfjKSX+DtPQah92zJK3wsoXsIkXqYoQjzzQMRPv3tARn1gfreC3DduVftD0+BpAcDqBxw64CsA+xQfrB5MCLhAEcliTAIBsWkrDfN5T+ghwjMU9aAfketZS5inDc2GRio=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Per kernel.org

snapshot: 3.1-rc1-git10 2011-08-14
[Patch] [View Patch]

mainline: 3.1-rc1 2011-08-08

Where you got 3.1.0-rc2 ?


--- On Mon, 8/15/11, Milan Holzäpfel <listen@xxxxxxxx> wrote:

From: Milan Holzäpfel <listen@xxxxxxxx>
Subject: [Xen-users] Kernel 3.1.0-rc2 hangs on boot, Xen 4.1.1
To: xen-users@xxxxxxxxxxxxxxxxxxx
Date: Monday, August 15, 2011, 7:48 AM


I tried out kernel 3.1.0-rc2 on my i386 Laptop with Xen 4.1.1.  Booting
hangs after these messages on the VGA console:

pci 0000:02:09.0: address space collision: [mem 0x000da000-0x000dafff] conflicts with reserved [mem 0x0009f800-0x000fffff]
reserve RAM buffer: 00000000 0009f000 - 00000000 0009ffff
reserve RAM buffer: 00000000 38400000 - 00000000 3bffffff
reserve RAM buffer: 00000001 07290000 - 00000001 07ffffff

The cursor hangs on the last line of this output.  I inserted some
space in the long memory address of the last three lines.  Is this
information of any use to Xen developers?

I believe that Ubuntu Oneiric's 3.0.0 kernel has the same problem, but
I cannot verify this, because VGA output is broken and the Laptop
doesn't have a serial port.

I also tried out from
git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git (branch
xen/stable-2.6.32.x).  This kernel boots fine under Xen, but it does
not boot on bare metal.

I've attached kernel .config and dmesgs for the combinations that did


-----Inline Attachment Follows-----

Xen-users mailing list
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.