[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Process blocked errors

I also had the same exact problem, with same exact config (stock Squeeze kernel). See http://www.mailinglistarchive.com/html/xen-users@xxxxxxxxxxxxxxxxxxx/2011-01/msg00595.html I have tried to build the latest driver for my RAID controler, but it didnt help.
In the end, the solution for me was to use a more recent Linux kernel from opensuse 11.4. So I have kept my Debien distro but I am "borrowing" the kernel from Suse. It works very well now. I have tried many many things without success.
Here is my "procedure" to install the Suse kernel with Debian :

apt-get --yes install alien
wget http://download.opensuse.org/distribution/11.4/repo/oss/suse/x86_64/kernel-xen-
alien -i kernel-xen-
echo CONFIG_XEN_DOM0=y >> /boot/config- && rm -f /boot/vmlinux-
update-initramfs -c -t -k -b /boot

Then you have to slightly edit /etc/init.d/xend to load the kernel modules, it should look like :

       modprobe evtchn 2>/dev/null || true
       modprobe blktap 2>/dev/null || true
       modprobe blkbk 2>/dev/null || true
       modprobe xenblk 2>/dev/null || true
       modprobe netbk 2>/dev/null || true
       modprobe gntdev 2>/dev/null || true
       modprobe usbbk 2>/dev/null || true

Hope it helps,
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.