[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Live migration timed out

On Tue, 2011-09-13 at 17:37 +0200, Sebastian Biedermann wrote:
Unfortunately, this is not working. I increased the number of loop
devices, I get the same error on node-2:

toor@node-2:/xen$ sudo mount /xen
toor@node-2:/$ cd /xen
toor@node-2:/xen$ ls
disk.img  my.lenny.cfg  swap.img
toor@node-2:/xen$ sudo xm create my.lenny.cfg -c
Using config file "./my.lenny.cfg".
toor@node-2:/xen$ Error: Device 51714 (vbd) could not be connected.
losetup /dev/loop0 /xen/disk.img failed

Did you reboot

Also, on node2, do you have read+write permissions on the NFS share? Are
you able to create a file in that directory?

I just read through your original email and was going down the wrong
path. My apologies.


Now I can boot the instance on node-2, I didnt had NFS root write privileges which I could get with the 'no_root_squash' option in the /etc/exports file. Thank you for that hint!

But the migration is still not working... it is just timing out..

toor@node-1:/xen$ sudo xm migrate 71 -l
Error: timed out

the xend.log file says:

[2011-09-14 10:27:31 1679] DEBUG (XendCheckpoint:124) [xc_save]: /usr/lib/xen/bin/xc_save 34 71 0 0 1 [2011-09-14 10:27:31 1679] INFO (XendCheckpoint:423) /usr/lib/xen/bin/xc_save: symbol lookup error: /usr/lib/xen/bin/xc_save: undefined symbol: xs_suspend_evtchn_port [2011-09-14 10:27:31 1679] ERROR (XendCheckpoint:178) Save failed on domain my.lenny (71) - resuming.
Traceback (most recent call last):
File "/usr/local/lib/python2.6/dist-packages/xen/xend/XendCheckpoint.py", line 146, in save
    forkHelper(cmd, fd, saveInputHandler, False)
File "/usr/local/lib/python2.6/dist-packages/xen/xend/XendCheckpoint.py", line 409, in forkHelper
    raise XendError("%s failed: popen failed" % string.join(cmd))
XendError: /usr/lib/xen/bin/xc_save 34 71 0 0 1 failed: popen failed
[2011-09-14 10:27:31 1679] DEBUG (XendDomainInfo:3117) XendDomainInfo.resumeDomain(71) [2011-09-14 10:27:34 1679] ERROR (xmlrpclib2:178) Internal error handling xend.domain.migrate
Traceback (most recent call last):
File "/usr/local/lib/python2.6/dist-packages/xen/util/xmlrpclib2.py", line 131, in _marshaled_dispatch
    response = self._dispatch(method, params)
  File "/usr/lib/python2.6/SimpleXMLRPCServer.py", line 418, in _dispatch
    return func(*params)
File "/usr/local/lib/python2.6/dist-packages/xen/xend/XendDomain.py", line 1366, in domain_migrate
    self._domain_migrate(dominfo, dst, live, port, node)
File "/usr/local/lib/python2.6/dist-packages/xen/xend/XendDomain.py", line 1458, in _domain_migrate
    dsterr = sock.recv(1024)
timeout: timed out

The port 8002 is open on both hosts, connections are possible... the xen config is configured..
I use exactly the same software versions on both hosts..

any ideas?

Thank you!


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.