[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] Unable to connect (with adition, device 0(vif) problem)

Ops, i forgot some other details, for problem 2, on command line, do : "sudo chmod 600 ifcfg-xenbr0" after saving so the file will have the same permition as ifcfg-eth0.


On Thu, 06 Oct 2011 17:49:17 -0300, andre@xxxxxxxxxxxxxxxx wrote:

Ok, as i was busy with XIII SIGE and some other stuff and I couldn't place the outcome, and as I noted that my doubt came out on google engine I will put here the correct answer for my problem so anyone else lookinf for it will be ok(and wont have to kill itself on command line as I had):

problem 1: unable to connect to 'localhost:8000': Connection refused...

Solution for problem 1: on command line, do "chkconfig xencommons off", run it as root or just sudo.


Then the second problem come after system reboot:

device 0 (vif) could not be connected Could not find bridge and none was specified...

Solution for problem 2: You need to creat xen-bridge, the following code worked for me, but some may need to change it, the line name its an example, look for your ethernet device and change it. Save as ifcfg-xenbr0 on /etc/sysconfig/network, backup ifcfg-eth0 and remove it or you will have conflict;


NAME='NetXtreme II BCM5709 Gigabit Ethernet'


For anyone who found this to be a solution, good luck :)


And thanks to who tried to help-me out.


André Pfeiffer

On Mon, 5 Sep 2011 21:59:07 -0500, Scott Meyers wrote:

You need to enable "xend-http-server" in /etc/xen/xend-config.sxp

Date: Mon, 5 Sep 2011 19:45:48 -0300
From: andre@xxxxxxxxxxxxxxxx
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Unable to connect

I have been using xen under open-suse 11.4 for almost half an year now. This week I had to reformat the provider and so I did install everything again (now there is a dual boot and microsoft windows server 2008 installed on the first half partition of the disk) again open-suse 11.4 and xen. I do start the xen kernel at grub but when I try to connect and/or creat a new domU the folling message come out:
"unable to connect to 'localhost:8000': Connection refused

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/connection.py", line 983, in _try_open
None], flags)
File "/usr/lib64/python2.7/site-packages/libvirt.py", line 107, in openAuth
if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: unable to connect to 'localhost:8000': Connection refused"
I do not remember having that problem before and the first time I booted the machine I was able to connect and start the new machine creation. Anyone can give-me a hint please?
Gratefull in advance,

_______________________________________________ Xen-users mailing list Xen-users@xxxxxxxxxxxxxxxxxxx http://lists.xensource.com/xen-users




Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.