[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] GPLPV, RDP and network latency


Has anybody experienced network latency problems with combination of Windows 7, 
GPLPV drivers and RDP connection?
Any Windows pop-up message(such as "command not found" error message in "Run 
command:" dialog, or dividing by zero in windows calc) causes a short freeze of 
RDP session and looks like that from dom0: 

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=128 time=0.649 ms
64 bytes from icmp_seq=2 ttl=128 time=0.232 ms
64 bytes from icmp_seq=3 ttl=128 time=0.273 ms
64 bytes from icmp_seq=4 ttl=128 time=501 ms                     
64 bytes from icmp_seq=5 ttl=128 time=0.205 ms
64 bytes from icmp_seq=6 ttl=128 time=0.463 ms
64 bytes from icmp_seq=7 ttl=128 time=0.206 ms

where is domU address. The latency may vary from 500 to 10000 ms.

The very same actions taken via VNC connection to VM work fine without any 
We have tried different Windows 7 distros, 32- and 64-bit editions, Windows and 
Linux RDP clients, with the same result. 

Software used:
Xen version 4.1.2_05-1.1.1 (abuild@) (gcc version 4.6.2 (SUSE Linux) ) Sun Oct 
30 03:25:04 UTC 2011
Windows 7 SP1

timer_mode is set to 1, offload settings are:
Offload parameters for vif2.0:
rx-checksumming: off
tx-checksumming: off
scatter-gather: off
tcp-segmentation-offload: off
udp-fragmentation-offload: off
generic-segmentation-offload: off
generic-receive-offload: off
large-receive-offload: off
rx-vlan-offload: off
tx-vlan-offload: off
ntuple-filters: off
receive-hashing: off

Thanks in advance!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.