[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xenconsole: Could not read tty from store: No such file or directory

On Mon, Mar 19, 2012 at 1:56 PM, Andreas Greve <andreas.greve@xxxxxxxxxx> wrote:
if it is a pv then look if the directory /var/log/xen/console exists. If some logging options in /etc/default/xen* are enabled xenconsoled does not start on boot. Because it could not write to /var/log/xen/console/hypervisor.log. The make install does not create the missing directory (4.1.2) .
I run in this problem today.
I hope the above helps you.


  Hi Andreas,

   Thanks for your reply. Interestingly, the file /var/log/xen/console doesn't exist on my machine. There is no any file or directory called /etc/default/xen*. So how did you address the similar problem? Could you please be a bit specific? Do I need to generate these files manually? Or  How can I generate these files automatically? Is this issue caused by these missing files?


Ian Campbell <Ian.Campbell@xxxxxxxxxx> schrieb:
On Sat, 2012-03-17 at 16:30 +0000, Su Zhang wrote:
> On Sat, Mar 17, 2012 at 3:24 AM, Ian Campbell
> <Ian.Campbell@xxxxxxxxxx> wrote:
> On Fri, 2012-03-16 at 23:45 +0000, Su Zhang wrote:
> > Hello Community,
> >
> > I encountered an error while running "xm console domU". Here
> is the
> > running script:
> >
> > # xm console domU
> > xenconsole: Could not read tty from store: No such file or
> directory
> >
> > I googled and found out that this issue is mostly result
> from
> > forgetting starting xenconsole service.
> > However, after I started xenconsole, the issue is still
&gt! ; there. Please

> > see:
> You might need to restart your guests and/or toolstack after
> starting
> xenconsole.
> This should all have been taken care of by the initscripts
> shipped with
> xen -- are you not using them for some reason?
> Ian,
> Do initscripts here refer to the xen-related scripts
> under /etc/init.d/ ?
> Like xencomms?

xencommons, yes.

> [...]

> [root@XenTester su]# virt-install -l
> http://mirror.centos.org/centos/5/os/i386/ -p -n f13 -r 768 --vcpus=1
> --disk=/srv/xen/mailserver.img --graphics vnc,listen=,port=5901
> --noautoconsole

I'm not at all familia! r with virt-install or Fedora but given this

domain is to be called "f13" I would have expected a Fedora mirror to be
listed rather than the CentOS 5 mirror. Is this normal?

Do you know if this command will create a PV or an HVM guest?

If this is an HVM domain then it is possible that it simply doesn't have
a text console which you can connect to with xl console. The "Could not
read tty from store" message is often indicative of this.

It appears you have configured VNC for this domain, have you tried
connecting a vncviewer to port 5901 on the host? e.g. vncviewer
localhost:1 or localhost::5091 (check the vncviewer manpage, I'm not
sure of the syntax). Perhaps virt-* includes a command to do this for
you automatically?

If you want a text console from an HVM guest then you can do the
virt-install equivalent of adding
series = 'pty'
to your guest configuration. I'm afraid I don't know h! ow to actually do

that with virt-install though.

If this is a PV guest then I have no idea what might be wrong.


Su Zhang
Ph.D Candidate
Computing and Information Sciences
Kansas State University
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.