[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] iSCSI disk disappears at boot (no boot device)

On Tue, Apr 17, 2012 at 9:04 PM, Fajar A. Nugraha <list@xxxxxxxxx> wrote:
The easiest way, and also the one with best performance in Xen, is to
import the iscsi disk in dom0 (i.e., your host). You then use it like
any other disk (e.g. /dev/sda, /dev/sdb, etc. Or use /dev/disk/by-id
or by-path for persistence).

That's what I'm doing.  I had to create an XML file in dom0 and made a pool which loads my iSCSI disks into /dev/disk/by-path.  Then for the OS installer in domU it just shows up like a regular disk and nothing special was required.  That's the part that has me stumped.  It worked just fine during the install - just during the boot is when it went awry.   But the fellow on the virt-manager list says that I cannot boot from iSCSI without in initiator.
I'm GUESSing you import the iscsi disk using the OS installer, AND you
use PV domU, which results in the disk (along with the kernel and
initrd) not accesible during domU boot.

No it is fully virtualized and see above.  So I dunno what to think at this point.  I'm ready to just give up and go back to VirtualBox to be honest.  Especially because since I started this project I only found out afterwards that Red Hat dumped Xen for 6.0 anyway.   
If you don't understand what
I'm saying on this paragraph, just forget it, and ONLY read the
previous paragraph :)

No I understood.  Ubuntu installer did not even have an option for importanting the iSCSI disk, but the CentOS installer did when I tried it.  BUt that's not what I used - as mentioned it just showed up like a regular disk since I'd imported it in dom0

So how do I go about debugging this?   I'd really like to get it going.  As much as I"m tempted to just go back to VirtualBox, I like the idea of Xen better.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.