[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] iSCSI disk disappears at boot (no boot device)

... tumbleweeds blow by ... :-)

I've been getting some response on the virt-manager list and someone just told me the following, which has me a bit confused :

Quote : "So to boot from iSCSI you need to use an iSCSI software initiator.
Like gPXE or so. "

What has me confused is that this worked fine with VirtualBox without any extra bits and pieces.   Does that mean that VirtualBox has the initiator built in but Xen does not?   And if not, then how is it I am able to connect the iSCSI disk to the VM (in virt-manager) in the first place?  I thought the mere fact that I can connected it requires that there is an initiator on one end ( xen / virt-manager ) and target on the other end (my iSCSI server)


On Fri, Apr 13, 2012 at 9:29 AM, Alan McKay <alan.mckay+xen@xxxxxxxxx> wrote:
Hey folks,

I tried this with both CentOS 5.8 and Ubuntu 12.04 (beta2) and same behavior.

Use virt-manager to create my VM.  I had previously used the virsh
commands to create an iSCSI pool (I think that is the right term) and
so my iSCSI disk shows up fine in virt-manager and I can add it to the

The install goes well the disk is there - I can either choose to
partition it manually or let it go automatic.  During the install from
the Ubuntu live CD I can open a shell and see the disk mounted and
stuff being installed to it.

After the install I can reboot from the Ubuntu live CD and I see the
iSCSI disk there.  I can mount stuff and look at it - looks like the
install went fine.

But I reboot and try to boot from the HD and it says :

Boot from Hard Disk failed: could not read the boot disk
FATAL: No bootable device

What's up with that?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.