[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] "undefined symbol: Py_InitModule4" xen4.1 installation on OpenSuse 12

I'am struggling to install xen-4.1.2_05-1.1.1.x86_64.rpm on OpenSuse 12. After overcoming quite a few problems, now the box is running xenlinux kernel. When I verify the installation by running "xend status", I get the following outputs:
# xend status
Traceback (most recent call last):
  File "/usr/sbin/xend", line 33, in <module>
    from xen.xend.server import SrvDaemon
  File "/usr/lib64/python/xen/xend/server/SrvDaemon.py", line 17, in <module>
    import xen.lowlevel.xc
ImportError: /usr/lib64/python/xen/lowlevel/xc.so: undefined symbol: Py_InitModule4
PS: python version is  2.7.
I tried solving it by seeking for relative info on google.com in vain. Is there anyone that has worked through this problem? How should I solve it?
Thanks a lot!
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.