[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Any tips on dealing with a super hung XAPI process?

  • To: xen-users@xxxxxxxxxxxxx
  • From: Jason Davis <scr512@xxxxxxxxx>
  • Date: Mon, 4 Jun 2012 19:03:55 -0500
  • Delivery-date: Tue, 05 Jun 2012 00:11:33 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

One of the cluster nodes (XS 5.6 SP2/not master) became unresponsive to XAPI calls being sent from a CloudStack management server. In the past, a simple xe-toolstack-restart would do the trick but the script timed out while restarting the XAPI daemon.

I found the process and first tried to use a simple kill command but the process was in a "defunct" state. I tried a kill -9 but no joy. 

I then found the xapi.pid and manually deleted it and then tried to run xe-toolstack-restart. Unfortunately this did not work and ultimately I had to reboot the cluster node.

So... any other ideas on killing a zombie XAPI process? I've like to avoid rebooting a host :)
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.