[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] QEMU networking on PV DomU

Hi, everyone
When I run QEMU on Dom0, I can use TAP device to set up networking for its guest.
For example, I use OpenVPN to control the TAP device tap0 and setup its IP address.

$ openvpn --mktun --dev tap0 --user `id -un`
$ ifconfig tap0 netmask up

I use QEMU's offical ARM test kernel and initrd disk image (arm-test-0.2.tar.gz) to execute QEMU and use tap0.

$ qemu-system-arm -kernel zImage.integrator -initrd arm_root.img -net nic -net tap,ifname=tap0,script=no,downscript=no

Then I change QEMU's guest IP address to, after that, I can ping host or TAP device from QEMU's guest.
But when I perform the above steps on PV DomU, I can't ping host or TAP device.
I tried to compile TAP device into kernel or as module, but none of them works.
Does anyone have the same problem? Any suggestions will be greatly appreciated, thanks in advance.

Best regards,

Yao-Jing Wen
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.