[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen 4.2 - xl error

  • To: xen-users@xxxxxxxxxxxxx
  • From: "Adam Gold" <awg1@xxxxxxx>
  • Date: Sun, 23 Sep 2012 22:16:59 +0200
  • Delivery-date: Sun, 23 Sep 2012 20:18:33 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Hi. ÂI'm not sure if I should be posting this to the dev list but the wiki 
mentioned trying here first. ÂI've just installed 4.2 on a host running ubuntu 
12.04 as follows:
- dependencies: apt-get build-dep xen && apt-get install libglib2.0-dev 
- build: ./configure; make world; make install

The following errors were reported during the compiling stage however I was 
able to proceed to make install:
make[3]: Entering directory `/root/xen-4.2.0/tools/firmware'
GIT=git /root/xen-4.2.0/tools/firmware/../../scripts/git-checkout.sh 
git://xenbits.xen.org/seabios.git rel- seabios-dir
/root/xen-4.2.0/tools/firmware/../../scripts/git-checkout.sh: 17: 
/root/xen-4.2.0/tools/firmware/../../scripts/git-checkout.sh: git: not found
make[3]: *** [seabios-dir] Error 127
make[3]: Leaving directory `/root/xen-4.2.0/tools/firmware'
make[2]: *** [subdir-install-firmware] Error 2
make[2]: Leaving directory `/root/xen-4.2.0/tools'
make[1]: *** [subdirs-install] Error 2
make[1]: Leaving directory `/root/xen-4.2.0/tools'
make: *** [install-tools] Error 2

I rebooted into the xen kernel (I manually selected it from the grub menu to be 
sure) and tried 'xl info'. ÂI received the following message: 'The program 'xl' 
is currently not installed. You can install it by typing: apt-get install 

I went ahead with the install specifying, when asked, to keep the currently 
installed scripts. ÂI tried 'xl info' again and received the following message: 
'ERROR: ÂCan't find version 4.2 of xen utils, bailing out!'

Next I uninstalled the package using 'apt-get remove xen-utils-common' and 
tried manually installing what seems to be like a 4.2 version here: 
http://packages.debian.org/experimental/all/xen-utils-common/download. ÂI still 
received the same error message after trying 'xl info' again.

FYI, I get the same error message when I try using xm.

Shouldn't the source code installation have included xen-utils-common? ÂAny 
suggestions on what I should be doing to solve this? ÂHappy to provide further 
info. ÂThanks in advance.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.