[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen 4.2 - xl error

On Mon, Sep 24, 2012 at 4:16 AM, Adam Gold <awg1@xxxxxxx> wrote:
> Hi.  I'm not sure if I should be posting this to the dev list but the wiki 
> mentioned trying here first.  I've just installed 4.2 on a host running 
> ubuntu 12.04 as follows:
> - dependencies: apt-get build-dep xen && apt-get install libglib2.0-dev 
> libyajl-dev
> - build: ./configure; make world; make install
> The following errors were reported during the compiling stage however I was 
> able to proceed to make install:
> make[3]: Entering directory `/root/xen-4.2.0/tools/firmware'
> GIT=git /root/xen-4.2.0/tools/firmware/../../scripts/git-checkout.sh 
> git://xenbits.xen.org/seabios.git rel- seabios-dir
> /root/xen-4.2.0/tools/firmware/../../scripts/git-checkout.sh: 17: 
> /root/xen-4.2.0/tools/firmware/../../scripts/git-checkout.sh: git: not found

Please read the error carefully... ... git: not found ... so you need
to install git first.


Kindest regards,
Giam Teck Choon

> make[3]: *** [seabios-dir] Error 127
> make[3]: Leaving directory `/root/xen-4.2.0/tools/firmware'
> make[2]: *** [subdir-install-firmware] Error 2
> make[2]: Leaving directory `/root/xen-4.2.0/tools'
> make[1]: *** [subdirs-install] Error 2
> make[1]: Leaving directory `/root/xen-4.2.0/tools'
> make: *** [install-tools] Error 2
> I rebooted into the xen kernel (I manually selected it from the grub menu to 
> be sure) and tried 'xl info'.  I received the following message: 'The program 
> 'xl' is currently not installed. You can install it by typing: apt-get 
> install xen-utils-common'.
> I went ahead with the install specifying, when asked, to keep the currently 
> installed scripts.  I tried 'xl info' again and received the following 
> message: 'ERROR:  Can't find version 4.2 of xen utils, bailing out!'
> Next I uninstalled the package using 'apt-get remove xen-utils-common' and 
> tried manually installing what seems to be like a 4.2 version here: 
> http://packages.debian.org/experimental/all/xen-utils-common/download.  I 
> still received the same error message after trying 'xl info' again.
> FYI, I get the same error message when I try using xm.
> Shouldn't the source code installation have included xen-utils-common?  Any 
> suggestions on what I should be doing to solve this?  Happy to provide 
> further info.  Thanks in advance.
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.