[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Clock problems on Squeeze/Xen4 (clock jumps 50 minutes ahead)

On 27 August 2012 20:04, Steve Dawson <sdawson@xxxxxxxxxxxxxxxx> wrote:

> We had this problem too, from what we could tell it was a hardware issue on 
> some of our servers, specifically HP DL380 G5 servers, we have G6's and G7's 
> as well, they don't seem to be affected.
> The fix was to boot the G5 servers with clocksource=pit and cpuidle=0 on the 
> xen command line. Example grub 1 entry below. Maybe the cpuidle switch is 
> needed too.
> title Xen-4.1.1
>        root (hd0,0)
>        kernel /boot/xen-4.1.1.gz dom0_mem=2048M dom0_max_vcpus=1 
> dom0_vcpus_pin clocksource=pit cpuidle=0
>        module /boot/vmlinuz- ro root=/dev/cciss/c0d0p1 max_loop=32

Hello, I have exactly the same problem on two HP Proliant DL580 G5
servers with debian squeeze.
It's very very annoying and I am also angry for this bug.
Is it a xen bug or a hardware problem?
I've tried clocksource=pit but I've not resolved.
Have you solved adding cpuidle=0?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.