[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Trouble with PCI Passthrough

Passthrough seems to be the most common problem, but I don't know enough of
the voodoo magic to understand where to start investigating my issue,
which is that passthrough works but only when passing through multiple

dom0: Fedora 17 with stock XEN (a later 4.1 version and a 3.5 kernel)
Hardware: VT-d capable MSI Z77 w/ i7-3770
Graphics cards:
      Intel HD 4000 IGD set as primary in the bios and used by dom0
      Radeon HD2600XT (from 2005ish) PCI-E slot 1, PCI 0000:01:00.[0,1]
      Radeon 7850 (brand new)              PCI-E slot 3, PCI 0000:02:00.[0,1]

What works:
    dom0 with the HD4000 IGD
    domU Windows 7 when both Radeon cards are passed through
              ie stubbing out 0000:01:00.[0-1] and 0000:02:00.[0-1]
and giving both to Win7

What doesn't work (and what I dont understand):
    domU Win7 when only one of the two devices is passed to Windows
(in which case I get the error 43) [tried it both ways, passing only
the 2600 or only the 7850, and same error either way]

Given that passthrough works, I dont understand why it would not work
when I only pass one of the devices. Is there something I should be
looking at (DMA ranges? IRQs?) to determine what linkage there is
between these two devices?


David Wright Escott
A comathematician turns cotheorems into phi.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.