[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-devel] Re: Xen 4 TSC problems

Hi Oliver


bad news, this means that xen 4.1xxx doesn’t solve this issue …


on my side, on my  hardware that produce this bug ,I never had the problem whit this combination : (100% WHEEZY)

ii  xen-hypervisor-4.1-amd64                  4.1.3-2                   amd64        Xen Hypervisor on AMD64

ii  linux-image-3.2.0-3-amd64                 3.2.23-1                  amd64        Linux 3.2 for 64-bit PCs


                (this was because I had a great hope that 4.1.xxx solved the problem …)






From: xen-devel-bounces@xxxxxxxxxxxxx [mailto:xen-devel-bounces@xxxxxxxxxxxxx] On Behalf Of Olivier Hanesse
Sent: Monday, October 15, 2012 9:40 AM
To: Mauro
Cc: Dan Magenheimer; xen-devel@xxxxxxxxxxxxxxxxxxx; Keir Fraser; Jeremy Fitzhardinge; Keir Fraser; Xen Users; Mark Adams
Subject: Re: [Xen-devel] [Xen-users] Re: Xen 4 TSC problems




Strange things on this rainy morning, I got this bug again on another hardware, and Xen hypervisor from Wheezy and kernel from Squeeze.


ii  linux-image-2.6.32-5-xen-amd64      2.6.32-46                  Linux 2.6.32 for 64-bit PCs, Xen dom0 support

ii  xen-hypervisor-4.1-amd64               4.1.3-2                      Xen Hypervisor on AMD64


I've upgraded this server last week. I don't know if it is linked or not, but I didn't get any 'time wrap' on this server for more than 250days.

Maybe it is related to the upgrade process. Before the upgrade, my version were :


ii  linux-image-2.6.32-5-xen-amd64   2.6.32-41squeeze2            Linux 2.6.32 for 64-bit PCs, Xen dom0 support

ii  xen-hypervisor-4.1-amd64            4.1.2-2                      Xen Hypervisor on AMD64


I only upgraded half of my servers, so I will wait a little bit to upgrade the other half and see if this issue occurs again only on updated servers.


For the record, always the same errors : 


xm dmesg => (XEN) Platform timer appears to have unexpectedly wrapped 10 or more times.


/var/log/*   => Oct 14 22:46:07 eul2400468 kernel: [734618.562219] Clocksource tsc unstable (delta = -2999660313370 ns)


I thought it was this issue was hardware related, maybe not.




2012/9/30 Mauro <mrsanna1@xxxxxxxxx>

On 30 September 2012 21:23, Mauro <mrsanna1@xxxxxxxxx> wrote:
> On 30 September 2012 17:13, Pasi Kärkkäinen <pasik@xxxxxx> wrote:
>> On Sat, Sep 29, 2012 at 02:19:55PM +0200, Mauro wrote:
>>> It's happened another time, system date 50 minutes ahead.
>>> There is really no solution?
>> Try with a recent Xen hypervisor version. Xen 4.1.3 or 4.2.0.
>> It helps a lot to know if the issue is still in the latest hypervisor versions or not.

There is someone that had the problem and solved using a recent xen hypervisor?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.