[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Memory missing

On 15/01/13 01:03, Adam Goryachev wrote:
> povder <povder@xxxxxxxxx> wrote:
>>> I installed debian testing with the debian testing version of xen
>> (4.1)
>>> and am using the xm/xend toolstack.
>> Do you have 32bit or 64bit system? "uname -a" command should print this
>> info.
> Should be 64bit I think:
> Linux pm01 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux
> Anywhere else I might look ?
I finally solved my "problem"...
I realised I only had this problem on two dom0 out of eight, so I
compared all files in /etc and then /boot, and started to panic since I
couldn't find any difference. I also compared the output of xm dmesg,
dmesg, xm info, etc... all returned basically identical information.

Finally, I compared the output of xm list, and suddenly, the light came
on :)

I had started a couple of domU's on the dom0 with the problem, hence it
had shrunk dom0 dynamically to release memory for the domU's. When I
shutdown (migrated the domU to a different dom0), the dom0 never grew
it's memory back up. I suppose there may be a manual method to tell the
dom0 to reclaim the memory, but in my case, a reboot solved the issue.

Sorry for wasting everyone's time, but hopefully this will help someone
else looking for some missing memory.


Adam Goryachev
Website Managers

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.