[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen 4.1.3, EFI boot and "no console to OS" problem

  • To: xen-users@xxxxxxxxxxxxx
  • From: Janno Loide <janno@xxxxxxx>
  • Date: Wed, 20 Mar 2013 13:21:16 +0200
  • Delivery-date: Wed, 20 Mar 2013 11:22:30 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


Based on what you've said, the KDM login is not frozen (cursor is actively blinking?), but the input is not in the right place somehow.

If I am understanding this right, the Java applet sits between the real VGA output and the Matrox adapter, as a layer? If so maybe some connection is belong list in transit when Xen hands VGA over to the Dom0.
Probably. Though I guess the problem isn't related to that applet, as the kernel without xen comes up with fully functional console.

The problem is probably Xen not supporting EFI -- at least on this hardware :( Actually, I was dumb enough not to look at 'xm dmesg' output before (thanks to Casey for bringing it up). Surprisingly, while Xen succeeds on detecting RAM, it fails reading full ACPI data structure:
(XEN) ACPI Error (tbxfroot-0218): A valid RSDP was not found [20070126]
(XEN) System RAM: 98237MB (100595124kB)
(XEN) Domain heap initialised
(XEN) Table is not found!
(XEN) Found and enabled local APIC!

As Xen does not detect root pointer it fails of course on everything else depending on it, including detecting the cpu:
(XEN) Detected 2000.055 MHz processor.
(XEN) Initing memory sharing.
(XEN) xstate_init: using cntxt_size: 0x340 and states: 0x7
(XEN) I/O virtualisation disabled
(XEN) Enabled directed EOI with ioapic_ack_old on!
(XEN) Platform timer is 1.193MHz PIT
(XEN) Allocated console ring of 16 KiB.
(XEN) VMX: Supported advanced features:
(XEN)  - APIC MMIO access virtualisation
(XEN)  - APIC TPR shadow
(XEN)  - Extended Page Tables (EPT)
(XEN)  - Virtual-Processor Identifiers (VPID)
(XEN)  - Virtual NMI
(XEN)  - MSR direct-access bitmap
(XEN)  - Unrestricted Guest
(XEN) HVM: ASIDs enabled.
(XEN) HVM: VMX enabled
(XEN) HVM: Hardware Assisted Paging (HAP) detected
(XEN) HVM: HAP page sizes: 4kB, 2MB, 1GB
(XEN) Brought up 1 CPUs
Finally, it just finds one cpu instead of six hyperthreaded cores! Amazing.
Compared to that, my trouble with console is just nothing.
The console problem is very likely caused by this acpi detection failure also.

Tried Opensuse 12.3 with Xen 4.2.1 this morning. Got the same result (the dmesg output above is actually from Xen 4.2.1 also).

The OS 12.3 kernel (3.7.10-1.1) without xen continues to detect ACPI data correctly (as 3.4.33-2.24 on 12.2 did), giving no errors, finding all cores etc...

I'll probably re-check the IBM firmware updates and then submit a bug report.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.