[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Storage recovery question / recommendations

I was an idiot. I made a mistake. Hopefully my up front admission of my error will help us get past the blasting I deserve.


I updated from xcp 1.1 to 1.6 – upon doing so and rebooting I tried to reattach the HBA storage I was using before – and was told it needed to be reinitialize (no problem I thought – I have good backups!).


Regrettably something that was backed up failed to restore… and will have to spend a lot of time recovering.


Can I ask what the underlying file system is?


Has anyone worked with a recovery company they can recommend?


Specifically I only REALLY need a single virtual hard drive – Ideally the whole vm would be nice - which was created late in the host server’s lifetime (so theoretically further into the disk).


Failing that, whatever FILES from that vhd that could be pulled would be great.


The reinit was fast – so it obviously didn’t WIPE the disk.



1)     Any information on underlying file system / advice on recovery methods etc.

2)     Any recommendations on consultants or firms who have fixed this sort of error for you?

3)     Any advice for the future on a way to remount an HBA device after an upgrade or an LVM if that’s preferred (and why does it default to HBA if LVM is better?) I’ve been reading but probably reading the wrong stuff as I don’t see a clear answer yet…


Thank you very much for you help in advance!





Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.