[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Wireless adapters on XEN

  • To: jacek burghardt <jaceksburghardt@xxxxxxxxx>, Casey DeLorme <cdelorme@xxxxxxxxx>
  • From: Dayo Egbetola <dxcp@xxxxxxxxx>
  • Date: Sat, 20 Apr 2013 21:50:27 +0100 (BST)
  • Cc: "Xen-users@xxxxxxxxxxxxx" <Xen-users@xxxxxxxxxxxxx>, Wei Liu <wei.liu2@xxxxxxxxxx>
  • Delivery-date: Sat, 20 Apr 2013 20:51:45 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=ymail.com; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=fvlm42G9Fq0nu9MVfEnew16sXUMZNO4nQj2kbi9Q1EQJ29BKhlLiy/IXi2J5lYx7LjXrEkXya72HBhO2jB0l3BpawImp/DR8zEVWqK9eERJJF4X5Wjx3KkzO1vwXjXSTq6MoSebc/m/3L8WzrhwXYZ5tiqDgBZJM9FD3xu7/Zwo=;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

thanks Jacek/Casey/Wei.

I'm all set. Here's what i did.

I reinstalled Ubuntu. Unfortunately, because the LVM volume for xen was set to use up the whole disk, i have to install it to a usb stick. Anyhow, it works. (May need to reinstall XEN or find a less brutal way to reclaim some of that disk currently used up by Xen)

Ubuntu detected the USB adapter during install but once it finished, i couldn't log into dom0 or identifiy it. Eventually, i changed the boot settings in the BIOS, rebooted and voila, on restart i get an ubuntu boot menu and after selecting the first entry, i get a command line asking for dom0 username etc.

Now i'm trying to get devstack installed, so i need to setup a domU according to the docs. It's downloading all the required items so i thought i'd update the list. 

Once this is all setup, i think i need a diagram to make sure i don't forget it all when i try to do it again.

Thanks again



From: jacek burghardt <jaceksburghardt@xxxxxxxxx>
To: Casey DeLorme <cdelorme@xxxxxxxxx>
Cc: Wei Liu <wei.liu2@xxxxxxxxxx>; "Xen-users@xxxxxxxxxxxxx" <Xen-users@xxxxxxxxxxxxx>; Dayo Egbetola <dxcp@xxxxxxxxx>
Sent: Sunday, 21 April 2013, 1:37
Subject: Re: [Xen-users] Wireless adapters on XEN

He seems to running xcp 1.6 so he has kernel version 2.6.32. Also xcp 1.6 iso based on centos 5.7 so If you want to get you get your wireless working you neet to look at centos howtos and make sure kernel supports usb device. Is there big difference between xcp on distro v xcp ios 

On Sat, Apr 20, 2013 at 1:14 PM, Casey DeLorme <cdelorme@xxxxxxxxx> wrote:
Hello Dayo,

Welcome to the mailing list.

Wei already covered this, but Xen/XCP rely on a control OS for you to interact, and anything you setup with the core hardware is initially handled by this Domain0.

My first step would be running `uname -a` or similar to verify what OS is your Domain0.  Then you can easily narrow down your search to the OS version without XCP.

Next I would check the kernel version from the Ubuntu you had and the new Domain0 you installed.  That could affect hardware compatibility and is worth investigating.

Someone else might have a more definitive answer, and hopefully it'll come down to simply running an extra command after connecting your USB device.

As for a reference to search the mailing list, you may want to check out their lists page, the link to marksmail is what you want:

Best of luck,


On Sat, Apr 20, 2013 at 1:26 PM, Wei Liu <wei.liu2@xxxxxxxxxx> wrote:
On Sat, Apr 20, 2013 at 03:06:37PM +0100, Dayo Egbetola wrote:
> hi all -
> I'm new here as i recently started playing with xen and xcp via
> ubuntu. It all worked fine but for better or worse, I decided i don't
> need ubuntu and wiped everything on my box and installed xcp from
> scratch. The only issue i now have is that i can't get it to connect
> to my router/internet.
> I have a netgear wireless usb adapter as well as a pci wireless nic on
> the machine. Xen has picked up the pci card, i think, as it is showing
> the settings in the Network and Management Interface and is ee it
> under ifconfig on the command line.
> On the other hand, the USB Adapter is not recognised however i can see
> it been detected when i removed and plug it in under dmesg | tail.
> The message says "new high speed USB device using ehci_hcd and address
> 7. configuration #1 chosen from 1 choice"
> It also doesn't show up under ifconfig
> My questions are 1. How do i get XEN to give me the options to select
> the wireless network and allow me to enter the user name, password,
> ssid etc?  2. For the USB adapter, how do i get this setup so that it
> shows up as an additional nic?

Xen is just a hypervisor. It exposes peripheral devices to Dom0. You
need Dom0 to take control of the devices.

>3. on a separate note, is there searcheable interface for the xen mail

Google works quite well.

> I've tried searching the web for some answers but nothing has turned
> up so far. Ideally, i'd like to use the usb adapter as it worked fine
> when i was using ubuntu. To get me going, i would have just used a
> wired  nic but it would be a shame to bring back the wires.

Ultimately there is always a Dom0 OS working. It looks like that Ubuntu
at least has the drivers you need. So why not stick with Ubuntu and
start from there.


> Appreciate the help
> regards
> Dayo

> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

Xen-users mailing list

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.