[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] ATI VGA Passthrough / Xen 4.2 / Linux 3.8.6

Gordan Bobic wrote
> On 04/22/2013 10:46 AM, Gizmo Chicken wrote:
>> Not sure if I can offer any wisdom, but I'll just note that secondary
>> GPU passthrough  has been pretty stable for me with Windows 7 combined
>> with a Radeon HD 6670 and the Catalyst 13.3beta3 driver.  But I confess
>> that I cheat a bit:  For this setup, I'm using XCP 1.6 as dom0 and am
>> managing guests with XenCenter.  I had GPU passthrough working with
>> vanilla Xen 4.x in the past.  But XCP 1.6 (which includes Xen 4.1) is
>> just easier.  But whatever your setup, you may wish to give the Catalyst
>> 13.3beta3 driver a try.  It works great for me.
> It got to the point where the VM won't actually start - it BSODs saying:
> "Attempt to reset the display driver and recover from timeout failed."
> in atikmpag.sys
> The only way I can boot it is either into safe mode, or by removing the 
> ATI card from the VM configuration. In safe mode the 13.3-beta driver 
> fails saying it failed to load the detection driver.
> While Windows 7 seems to have lasted a few reboots more, ultimately it's 
> still no more usable than XP considering it won't even boot any more.
> Any debugging ideas welcome.
> Thus far the only noteworthy thing I've changed (to no obvious positive 
> effect) is putting the VGA passthrough GPU into a different slot so that 
> it is the only thing on that particular PCIe bridge.
> Gordan
> _______________________________________________
> Xen-users mailing list

> Xen-users@.xen

> http://lists.xen.org/xen-users

I've signed up to this mailing list simply because your situation mirrors my
own.  Allow me to elaborate, my setup is as follows:

Processors = 2x Intel E5440 Xeons (Harpertown)
Motherboard = SuperMicro X7DWA-N 
Graphics = 
1x ATI Radeon 5870 1GB (PCIe Slot 1 -- Primary card in BIOS)
1x ATI Radeon 5570 1GB (PCIe Slot 6 -- Secondary; No POST messages on boot)

I'm running Xen 4.2.1 with patches applied to qemu-dm for ATI primary
My dom0 is Fedora 18.  My grub commandlines are:

GRUB_CMDLINE_XEN="iommu=1 dom0_mem=10240M"

The lspci listing for my cards has the 5870 (used by dom0) at 01:00.0, and
01:00.1 (HDMI audio)
The same listing has the 5570 (hidden by pciback) at 02:00:0, and 02:00.1 

I've tried Windows 7 in both x86 and x64 as domU and my results are sporadic
but neither yields a display on my second monitor.  The bitness seems not to
matter, but the results vary when using different driver versions as well as
using CCC.

When using the 10.x series Catalyst drivers, the system boots, recognizes
the card, and even shows the monitor in "Screen Resolution" settings.  But
when I attempt to "Extend the Display" to the monitor on my 5570, the system
hangs for a moment, then BSODs.  (Not to atikmpag.sys or atikmdag.sys but a
different driver that escapes me at present, Error 8E).  Upon reboot
however, the system crashes immediately with a BSOD in atimkpag.sys.  

When using the 11.x or above drivers, the system crashes whether CCC is
installed or not, again with a BSOD in atikmdag.sys Error 116.

I have several theories as to why my setup is failing:

1) I'm using a Dual CPU system, and this is somehow causing problems with
ownership and separation of PCIe devices on the same bus?  I don't know if
this is possible.

2) I'm using a system with no integrated graphics adapter, but that relies
on 2 discrete graphics cards, both Radeons.  In order to use dom0, I need to
initiate the primary adapter in the first PCIe slot (5870).  I do not have a
second machine to test this.

3) Xen cannot pass-through one card in a two card configuration when dom0 is
using one of the cards.

4) Xen cannot pass-through the secondary card in a two card configuration. 
It must be the primary card, and the OS must use the secondary card. 
Perhaps a hardware limitation of VT-d?

I've been working on a solution for days, and to this point I'm somewhat
stumped.  I'm going to attempt to change the BIOS settings to use the
secondary card in Slot 6 (5570) as the primary card, and pass through the
card at address 01:00.0  (5870).  Maybe that will yield results?

I hope anyone can help me resolve this situation.

View this message in context: 
Sent from the Xen - User mailing list archive at Nabble.com.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.