[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] ERROR: Toolstack not specifed and nothing detected, bailing out!

  • To: Ian Campbell <Ian.Campbell@xxxxxxxxxx>
  • From: Simon Jones <Simon@xxxxxxx>
  • Date: Fri, 3 May 2013 14:09:07 +0000
  • Accept-language: en-GB, en-US
  • Cc: "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • Delivery-date: Fri, 03 May 2013 14:10:49 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>
  • Thread-index: Ac5IA4F8B5zecBfgRqSJFojHrFFIOv//9CaA///sOrA=
  • Thread-topic: [Xen-users] ERROR: Toolstack not specifed and nothing detected, bailing out!

-----Original Message-----
From: Ian Campbell [mailto:Ian.Campbell@xxxxxxxxxx] 
Sent: 03 May 2013 14:56
To: Simon Jones
Cc: xen-users@xxxxxxxxxxxxx
Subject: Re: [Xen-users] ERROR: Toolstack not specifed and nothing detected, 
bailing out!

On Fri, 2013-05-03 at 14:44 +0100, Simon Jones wrote:
> I have just installed Xen by following 
> http://wiki.xen.org/wiki/Xen_Beginners_Guide
> All in all pretty good, however it mentions using the xl toolset but 
> when I first installed only the xm toolset would work.

Some of that wiki page strikes me as a bit odd, it looks a bit like someone has 
done a search and replace xm->xl without considering the context (Debian 
Squeeze, which uses xm by default)

Which Debian release are you using? If you are using Squeeze then IMHO you 
should stick with xm.

You might have better luck with: http://wiki.debian.org/Xen 

>  This was great for creating linux based domains but it gave me an 
> error about hvm when I tried creating a Windows domain.

If on Squeeze did you install the qemu-dm-xen package?

> I then apt-get install xen-tools-common and edited /etc/default/xen to 
> specify the xl toolset, rebooted and tried again.  This time when 
> doing xl info the system returned:

Do you mean xen-utils-common? xen-tools-common is not a package which exists in 
Debian and xen-tools is a 3rd party set of utilities for working with Xen once 
you have it installed and working.

Even if you meant xen-utils-common I'm a bit confused what you have done here, 
are you trying to mix and match an installation from source with the Debian 
binary package xen-tools-common? That isn't going to work, xen-tools-common is 
for use with the Debian binary package of Xen.

If you are installing from Debian packages only then I don't understand why you 
needed to install xen-tools-common by hand, since it should have been pulled in 
by the dependencies when you install the xen-linux-system package.

Likewise I don't see how you were able to remove xen-utils-common without also 
removing other critical xen packages.


Thanks Ian, 

Got it working again and am back to the original error:

root@xen-1:~# xm create /etc/xen/windows8.cfg
Using config file "/etc/xen/windows8.cfg".
Error: Errors were found at line 2 while processing /etc/xen/windows8.cfg:

here's the config file:

kernel = "/usr/lib/xen-4.0/boot/hvmloader"
   memory = 4096
   name = "ovm-1734"
   vif = ['bridge=xenbr0']
   disk = 
   acpi = 1
   device_model = 'qemu-dm'

I'm still getting my head around the system (clearly!) so apologies if I'm 
messing up something too obvious...
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.