[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen Reports no IOMMU, but Hardware Supports It


There is no option for VT-d in the BIOS. However, there is an option for Intel Virtualization Technology (VT-x), which is enabled. Even though there's no option for VT-d, according to [1], the board (DH77DF) supports VT-d.


Philip Wernersbach
Software Implementation Division
Jacobs Automation


On Wed, May 15, 2013 at 5:55 AM, chris <tknchris@xxxxxxxxx> wrote:
Did you enable VT-d in the bios? It must be enabled in the bios for it to work

On Tue, May 14, 2013 at 10:21 PM, Philip Wernersbach
<pwernersbach@xxxxxxxxxxxxxxxxxxxx> wrote:
> Hello Everyone,
> My company is in the process of implementing Xen virtualization. We have
> managed to get Xen up and running, and have worked through all of the kinks
> in our set up, except for PCI passthrough. PCI passthrough doesn't work, and
> I suspect it's because Xen is not using the IOMMU in the computer, even
> though we built the computer with components that support VT-d.
> Here are the computer components we used:
> Motherboard: Intel BOXDH77DF
> CPU: Intel Core i5-2310 (Sandy Bridge - BX80623I52310)
> I also booted Xen up with the "iommu=verbose" parameter and ran "xl dmesg"
> on the computer, and uploaded the output here: http://pastebin.com/rF0kyftt.
> I tried running Xen with the "iommu=required" flag, and it failed because it
> said it couldn't use the IOMMU. If someone work with us to figure out why
> Xen doesn't use the IOMMU, it would be very appreciated.
> Thanks.
> Philip Wernersbach
> Software Implementation Division
> Jacobs Automation
> _______________________________________________

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.