[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Cold Migration Error

  • To: "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Joshua Tuttle <jtuttle@xxxxxxxxx>
  • Date: Wed, 3 Jul 2013 16:34:10 +0000
  • Accept-language: en-US
  • Delivery-date: Wed, 03 Jul 2013 16:35:36 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>
  • Thread-index: AQHOeAgt7rE+/G3JlEOuZfwiSgnERg==
  • Thread-topic: Cold Migration Error


I seem to be having a problem with performing a cold migration that I'm having a hard time find a solution to.

I have two machines that are on a local network that I am trying to perform the migration with. They are both running Debian 7.0 as the dom0 and Xen 4.2.2 (compiled from source). Both machines have supported Intel processors for virtualization as well. On the fist machine I have a domU called "joshtest" that I save the state with the command "xl save joshtest joshtest.checkpt"

I then transfer the joshtest.img and joshtest.checkpt to the same locations they were at on the first machine to the second machine.

After the files are transfered I run the command "xl restore joshtest.checkpt", and it produces this output:

     root@debian:/etc/xen# xl restore joshtest.checkpt
     Loading new save file joshtest.checkpt (new xl fmt info 0x0/0x0/155)
     Savefile contains xl domain config
     Parsing config from <saved>
     xc: error: error setting the HVM context (1 = Operation not permitted): Internal error
     Daemon running with PID 4337

Even with this output, the domain still runs. However it seems to be in a frozen state. The output of the "xl top" command shows no activity and has no value for state. When I view the domain, I can't perform any operation.

The output of the "xl dmesg" provides the following:
    (XEN) Freed 268kB init memory.
    (XEN) HVM1 restore: bad CR4 0x1406f0
    (XEN) HVM1 restore: failed to load entry 2/0
    (XEN) HVM2 restore: bad CR4 0x1406f0
    (XEN) HVM2 restore: failed to load entry 2/0
    (XEN) HVM3 restore: bad CR4 0x1406f0
    (XEN) HVM3 restore: failed to load entry 2/0
    (XEN) HVM4 restore: bad CR4 0x1406f0
    (XEN) HVM4 restore: failed to load entry 2/0
    (XEN) HVM5 restore: bad CR4 0x1406f0
    (XEN) HVM5 restore: failed to load entry 2/0
    (XEN) HVM6 restore: bad CR4 0x1406f0
    (XEN) HVM6 restore: failed to load entry 2/0
    (XEN) HVM7 restore: bad CR4 0x1406f0
    (XEN) HVM7 restore: failed to load entry 2/0

With the operation not permitted error, it makes me think it could be some type of permissions issue, but I have tried chown and chmod on both files and it doesn't change anything.  With the output of the "xl dmesg", it looks like it has something to do with the processor state.

Any help would be greatly appreciated!



This message and all attachments are PRIVATE, and contain information that is PROPRIETARY to Intelligent Automation, Inc. You are not authorized to transmit or otherwise disclose this message or any attachments to any third party whatsoever without the express written consent of Intelligent Automation, Inc. If you received this message in error or you are not willing to view this message or any attachments on a confidential basis, please immediately delete this email and any attachments and notify Intelligent Automation, Inc.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.