[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] PXE booting XenServer 6.2

  • To: xen-users@xxxxxxxxxxxxx
  • From: Alexandre Kouznetsov <alk@xxxxxxxxxx>
  • Date: Tue, 09 Jul 2013 10:58:37 -0500
  • Delivery-date: Tue, 09 Jul 2013 15:59:33 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


El 09/07/13 08:17, Prasanna Santhanam escribió:
On Mon, Jul 08, 2013 at 02:24:32PM +0000, Joseph Hom wrote:
Try removing all the extra consoles. Also maybe specify a ramdisk
for root. I usually have something like this for my pxe cmdline and
it installs 6.2.0 without issues.

   append XENSERVER_6.2.0_64/xen.gz --- XENSERVER_6.2.0_64/vmlinuz
   root=/dev/ram0 ramdisk_size=32758 atexit=shell
   answerfile=http://answerfile install ---

Thanks, I tried this and it worked for xcp 1.6 and xen 6.0.2 but
didn't for xen 6.2. Still stuck on the console line:

I'm successfully booting XS 6.2 installation via PXE. So far it boots on a VirtualBox VM, but can't get beyond networking detection. It seems something is wrong with the dhclient in XS 6.2 initrd. I have not tested it on physical hardware yet.

Maybe yours is the same problem, maybe not. This are some points worth checking:

1. Make sure the option "redirect console after boot" is disabled in your BIOS. I'm not sure what this option is intended for, but I find it messes up things when playing with serial console. It is not needed to be enabled for a serial console setup with Linux.

2. When using serial console, on previous versions of Xen, I have seen some output to be missed, it was not copied to both, the physical and serial console. My solution was to decide which I use and not to count on the other one. Since you are using a iDRAC card, which gives you a "normal" graphical console, consider dropping the serial console and omit it's reference from the boot configuration.

3. Check your serial ports configuration in BIOS. What is mapped as com1, the internal port or the external one? If it's external and there is something connected to it, it may confuse the console.

4.Check the debug virtual console (Alt-F2, hope your iDRAC can do it). It's possible that something went wrong with your answers file or networking detection.

5. Try booting without answers file first. With answers file, since the process is supposed to be unattended, the feedback is poor.

This is my boot configuration (mostly copied from my XCP 1.6 install setup):
append deploy/XenServer-6.2.0-install-cd/boot/xen.gz dom0_mem=752M com2=115200,8n1 console=com2,vga --- deploy/XenServer-6.2.0-install-cd/boot/vmlinuz console=tty0 xencons=hvc console=hvc0 --- deploy/XenServer-6.2.0-install-cd/install.img

For reference, in production I use serial console on com2, mapped to my PowerEdge's internal serial port, which I access via IPMI SOL.


Alexandre Kouznetsov

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.