[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] HVM DomU+Dom0 crash with PCI USB passthrough

Hello everyone,

ultimately, I'm trying to get VGA passthrough, ideally with the AMD
A10 integrated graphics, to work. My mainboard is an ASRock FM2A75
Pro4, which supports IOMMU.
I had started a thread on July 14 (see here:
http://lists.xen.org/archives/html/xen-users/2013-07/msg00172.html ).
Since then, I have been given an old PCIe card that identifies itself
as "ATI RV515 [Radeon X1300]" in lspci (it's manufactured by MSI, but
from physical inspection, I couldn't tell any further details, like
model numer.)
Now, I again tried to make VGA passthrough work, but failed before I
could really attempt it:

I installed a Win7 x64 DomU from scratch, which worked fine.
However, when I try to access a pendrive from a passed-through USB
controller in DomU, DomU hangs. In Dom0, when I press one button on
the keyboard, it acts as if I kept pushing the button down and never
releasing it. Other than that, I'm unable to do anything in Dom0. WiFi
seems also to be lost.
This keeps happening to me. Interestingly though, the first time I
tried today, I had no issues at all, but no luck since then.

What may be relevant is that I get the following message when I issue
"xl create xenwin.cfg":
libxl: error: libxl_pci.c:990:libxl__device_pci_reset: The kernel
doesn't support reset from sysfs for PCI device 0000:00:12.0

I'm running kernel 3.10.1 on Mint 15, with xen sources checked out
from git on July 27, commit 704302ce9404c73cfb687d31adcf67094ab5bb53.
Kernel config: http://pastebin.com/LVsKEWdM
DomU config: http://pastebin.com/tHwQHUiA

What can I do to resolve this?
Any help is highly appreciated, and I'm very willing to help debug
this should this not be due to a configuration error.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.