[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] fresh xcp 1.6 & xenserver install fails on first boot (kernel not found).

Errol - thanks!

I saw a post people made about rebuilding initrd (mkinitrd --with-usb) and gave 
that a shot.

My backgroud is more freebsd than linux - and that feels rusty. It feels like 
it may be the issue (a missing driver) but how do I tell?

Dump dmsg from a shell boot on the xenserver and compare it how?

Thanks again. I tried copying /sys/block/* (I read it in a seemingly related 
how to) and ran mkinitrd but that did not help.

Thanks again,


Errol Neal <eneal@xxxxxxxxxxxxxxxxx> wrote:

On Sat, 09/21/2013 05:45 PM, "mitch@xxxxxxxxxxxx" <mitch@xxxxxxxxxxxx> wrote:
> Hi - I posted the question to the xenserver install forum a couple days ago 
> but haven't had any luck (no reply) - then tried xen-api about a day ago, but 
> I haven't seen any traffic on that list - I checked the archives to confirm 
> my message is there - just low low low traffic.
> I know this isn't really the right place (I'm sorry), but I'm betting 
> (hoping) someone can help and getting more desparate for an answer.
> http://forums.citrix.com/thread.jspa?threadID=337104
> I've tried XCP 1.6 and the current Xenserver download.
> I have installed both xen and xcp several times previously, but this is the 
> first time I've seen this issue.
> The install completes as expected, and I'm asked to remove the media from the 
> dvd drive.
> On reboot I get a page of gibberish.  After pressing ENTER a few times I 
> noticed what I thought was text...
> Could not find kernel image: <gibberish and seeming random crud>
> boot:
> The hardware (I have used similar before) has an intel srcs16 RAID controller 
> - the controller is detected by the installer - the install seems fine - a 
> rescue linux disk (centos) can see the installed xcp partition and mount them 
> / read the files.

Boot using the CD, mount the partition and examine the initrd image and make 
sure your driver is in there.
I can't imagine it not booting if the ISO booted just fine.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.