[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] pci-passthrough to a pv domu worked in xen 4.2.2, but not in 4.3.0

Hello David,

On Sun, Oct 06, David Sutton wrote:

> On Sun, Oct 6, 2013 at 1:54 PM, Dieter Bloms <xensource.com@xxxxxxxx> wrote:
> > Hello,
> >
> > my dom0 is an alpinelinux installed with kernel 3.10.14-1-grsec and xen
> > 4.2.2.
> > My domU is an opensuse 12.3 with all patches installed.
> > The system works great, but when I do only switch xen from 4.2.2 to
> > 4.3.0 (packages from http://nl.alpinelinux.org/alpine/edge/main/x86_64/)
> > then my kernel in the domU does an Oops and the drivers for my dvb card
> > aren't loaded successfully.
> >
> > When I switch back to xen 4.2.2 (packages from
> > http://nl.alpinelinux.org/alpine/v2.6/main/x86_64/) it works great.
> >
> > Does anybody have a clue, what I can do to get it working ?
> >
> > I've attached my domU config, output of lspci -v and the dmesg, from the
> > domU.
> >
> >
> The default device model was changed with 4.3.0 and the new one isn't
> currently as compatible. Try adding the following line into your config to
> use the traditional model again:
> *device_model_version = "qemu-xen-traditional"

this doesn't help.
As far as I can see this is for hvm domUs, only.
I have to use pv domUs, because of missing IOMMU.

I've tried pci=nomsi for domU kernel, but also no success.



I do not get viruses because I do not use MS software.
If you use Outlook then please do not put my email address in your
address-book so that WHEN you get a virus it won't use my address in the
From field.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.