[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problem in building vTPM manager

Thanks Daniel,

When I run

sudo xl create -c vtpmmgr-stubdom.cfg

I receive the following error:

Parsing config from vtpmmgr-stubdom.cfg
Daemon running with PID 29361
Xen Minimal OS!
  start_info: 0xa2000(VA)
    nr_pages: 0x1000
  shared_inf: 0x83ad7000(MA)
     pt_base: 0xa5000(VA)
nr_pt_frames: 0x5
    mfn_list: 0x9a000(VA)
   mod_start: 0x0(VA)
     mod_len: 0
       flags: 0x0
  stack:      0x597e0-0x797e0
MM: Init
      _text: 0x0(VA)
     _etext: 0x39357(VA)
   _erodata: 0x45000(VA)
     _edata: 0x47c40(VA)
stack start: 0x597e0(VA)
       _end: 0x99e00(VA)
  start_pfn: ad
    max_pfn: 1000
Mapping memory range 0x400000 - 0x1000000
setting 0x0-0x45000 readonly
skipped 0x1000
MM: Initialise page allocator for b3000(b3000)-1000000(1000000)
MM: done
Demand map pfns at 1001000-2001001000.
Heap resides at 2001002000-4001002000.
Initialising timer interface
Initialising console ... done.
gnttab_table mapped at 0x1001000.
Initialising scheduler
Thread "Idle": pointer: 0x2001002050, stack: 0xd0000
Thread "xenstore": pointer: 0x2001002800, stack: 0xe0000
xenbus initialised on irq 1 mfn 0x2302d8
Thread "shutdown": pointer: 0x2001002fb0, stack: 0xf0000
Dummy main: start_info=0x798e0
Thread "main": pointer: 0x2001003760, stack: 0x100000
Shutting down ()
Shutdown requested: 3
Thread "shutdown" exited.
INFO[VTPM]: Starting vTPM manager domain
INFO[VTPM]: Option: Using tpm_tis driver
******************* BLKFRONT for device/vbd/768 **********

backend at /local/domain/0/backend/qdisk/22/768
Failed to read /local/domain/0/backend/qdisk/22/768/feature-barrier.
32768 sectors of 512 bytes
blk_open(device/vbd/768) -> 3
============= Init TPM BACK ================
Thread "tpmback-listener": pointer: 0x20010043f0, stack: 0xf0000
============= Init TPM TIS Driver ==============
IOMEM Machine Base Address: FED40000
Enabled Localities: 0
Map 1 (fed40, ...) at 0x1006000 failed: -1.
Do_exit called!
base is 0x10fcb8 caller is 0x1f24d
base is 0x10fcd8 caller is 0x27658
base is 0x10fd88 caller is 0x2772b
base is 0x10fde8 caller is 0x26bf6
base is 0x10fe28 caller is 0x26c1e
base is 0x10fe38 caller is 0x1ba94
base is 0x10fe78 caller is 0x6f84
base is 0x10ff38 caller is 0x353c
base is 0x10ff68 caller is 0x1fa80
base is 0x10ffe8 caller is 0x343b

How I can solve this problem?
Note: I had tcsd running on dom0, which I killed before I run the command.

On Fri, Sep 27, 2013 at 2:39 PM, Daniel De Graaf <dgdegra@xxxxxxxxxxxxx> wrote:
On 09/27/2013 02:17 PM, Emma Allison wrote:

I use Xen 4.3.0. When I build the source using "make world", the file
vtpmmgr-stubdom.gz is not created. Based on the documentation, manager
config file requires the path to this file to be specified.

Is there any flag that I have to set, or any trick for building vTPM


You likely need to install cmake and then rerun ./configure. You can also
run "./configure --enable-vtpmmgr-stubdom" to make missing dependencies

Daniel De Graaf
National Security Agency

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.