[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problem in building vTPM manager

On 10/11/2013 07:09 PM, Emma Allison wrote:
Thanks Daniel,

When I run

sudo xl create -c vtpmmgr-stubdom.cfg

I receive the following error:

IOMEM Machine Base Address: FED40000
Enabled Localities: 0
Map 1 (fed40, ...) at 0x1006000 failed: -1.
Do_exit called!
base is 0x10fcb8 caller is 0x1f24d
base is 0x10fcd8 caller is 0x27658
base is 0x10fd88 caller is 0x2772b
base is 0x10fde8 caller is 0x26bf6
base is 0x10fe28 caller is 0x26c1e
base is 0x10fe38 caller is 0x1ba94
base is 0x10fe78 caller is 0x6f84
base is 0x10ff38 caller is 0x353c
base is 0x10ff68 caller is 0x1fa80
base is 0x10ffe8 caller is 0x343b

How I can solve this problem?

This is fixed by a hypervisor patch in xen-unstable:


That patch has not yet been applied to the 4.3 tree, however you can apply
it yourself. I'm adding Jan to CC as a ping to backport this patch; a
report on if the patch fixes the issue may also be helpful here.

Note: I had tcsd running on dom0, which I killed before I run the command.

On Fri, Sep 27, 2013 at 2:39 PM, Daniel De Graaf <dgdegra@xxxxxxxxxxxxx>wrote:

On 09/27/2013 02:17 PM, Emma Allison wrote:


I use Xen 4.3.0. When I build the source using "make world", the file
vtpmmgr-stubdom.gz is not created. Based on the documentation, manager
config file requires the path to this file to be specified.

Is there any flag that I have to set, or any trick for building vTPM


You likely need to install cmake and then rerun ./configure. You can also
run "./configure --enable-vtpmmgr-stubdom" to make missing dependencies

Daniel De Graaf
National Security Agency

Daniel De Graaf
National Security Agency

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.