[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Blank screen when starting X with Dom0 loaded fglrx Radeon M6700

  • To: "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Art Napor <artnapor@xxxxxxxxx>
  • Date: Sun, 13 Oct 2013 14:56:25 -0700 (PDT)
  • Delivery-date: Sun, 13 Oct 2013 21:57:49 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:Message-ID:Date:From:Reply-To:Subject:To:MIME-Version:Content-Type; b=Au6uigWZXtJo8pEakMXzx9tGdSKZgvwelD9AigzaO73w6Uu5F76mcPw80AO24OkmHpoGsviiHab3zIr0rG323iKRieisW9YPVxjrSIlZlwKny2mPqkStwACs7ZA+/Y21X53RoVNi4S7+l/ODD/O6AidFqJ7SB6AZ08/MO2f3RqI=;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Greeted by a blank screen when X starts when booting Dom0. Booting without Dom0, X starts. Have tried latest official, beta, and elrepo fglrx drivers with the same result.

Kernel version is 3.4.53-8.el6.x86_64.
Xorg: Xorg-1.13.0-11
Xen version is 4.2.3.
Device: 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series].

I noticed a series of these in the xl dmesg:

(XEN) traps.c:2592:d0 Domain attempted WRMSR 0000000000000079 from 0x0000000000000000 to 0xffffc900089cc030.

I found a similar thread with a patch referenced and applied & rebuilt the kernel. No change.


I also looked at the DRM documentation - I think the kernel and Xen version's that I'm using support DRM. Also tried iommu=1 & 0, radeon.modetest=0 & 1, and nopat grub options.  

Non-working Xorg


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.