[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough with Xen 4.3 and Qemu 1.7 on Debian Jessie

Hello Volker,

Can you supply more information about the system. ÂThere are many possibilities, so it'll be hard to narrow it down with only what you have provided.

- What does the domu.cfg look like (complete copy)
- Can you supply your kernel config
- Any notable hardware (eg. motherboard?)
- run `xl -vvv create` and attach the output

I have been using Xen 4.3 and 4.4 on Wheezy for some time now, but I have not yet tried with Jessie. ÂOff the top of my head, three possibilities stand out. ÂCould be a syntax error in your domu.cfg (review the latest man pages: http://xenbits.xen.org/docs/4.3-testing/man/xl.cfg.5.html). ÂI still build pciback into my kernels as I have never had good luck with late device binding even with though the xl toolstack should do so; is pciback compiled into the kernel and your devices hidden by grub, or are you relying on late binding? ÂThere have been problems with larger amounts of memory. ÂHave you tried dropping to 1~2 GB of ram in your config (yes I am aware that it is a very small amount for Windows to run well on, maybe try it just to confirm possible causes)?

Send us more info.



On Sun, Dec 8, 2013 at 7:58 AM, Volker Klasen <reklov@xxxxxxxxxxxxxxxx> wrote:
Hash: SHA1


the short version: I can't get VGA passthrough working with Xen 4.3
and Qemu 1.7. The VM won't even display a bios screen.

The long version: after successfully running Windows 7 64bit with a
passthrough'd Radeon HD 7870 about 1.5 years with Xen 4.1
(xm/qemu-dm), I decided it was time to upgrade to Jessie's current Xen
packages (4.3).

Unexpectedly, I came across several issues related to switching from
xm to xl and from qemu-dm to qemu, as well as non-functional VGA
passthrough. I found 2 setups that at least would start the VM:

1) Using qemu-dm from Wheezy packages xen-utils-4.1
In this setup I can pass through all 4 PCI devices (USB controller,
VGA card, HDMI audio and audio card), however, none is working. For
the audio card error 10 is reported, for the graphics card error 43.

2) Using qemu
In this setup PCI passthrough works as long as I do not passthrough my
VGA card (the other three are working without problems). As soon as I
passthrough the graphics card, the VM won't even startup at all (vnc
is running but no bios is displayed, only black screen); the logs are
empty, as well (the only line is "Waiting for domain ..." in

I tried setting and unsetting the pci_* options in the domain config
file but I had no luck. Here's my current config (left some unrelated
things out) set up for 2) with VGA passthrough (01:00.0):

# qemu
device_model_override = '/usr/bin/qemu-system-x86_64'
# qemu-dm
#device_model_override = '/usr/lib/xen-4.1/bin/qemu-dm'

builder = 'hvm'
viridian = 1
vga = 'stdvga'
pci_msitranslate = 0

#pci = ['0000:00:1d.0','0000:01:00.1','0000:04:04.0']
pci = ['0000:00:1d.0','0000:01:00.0','0000:01:00.1','0000:04:04.0']

Has anyone an idea what I could try?

Version: GnuPG v1.4.15 (GNU/Linux)
Comment: Using GnuPG with Icedove - http://www.enigmail.net/


Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.