[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough with Xen 4.3 and Qemu 1.7 on Debian Jessie

Hash: SHA1

Hi Casey,

> Can you supply more information about the system.  There are many 
> possibilities, so it'll be hard to narrow it down with only what
> you have provided.

I'll do:

> - What does the domu.cfg look like (complete copy)

I just did a new test without any disks so we can discard the guest OS
as the cause. With my graphics card (0000:01:00.0) passed through the
BIOS is not displayed; without (0000:01:00.1 is the HDMI device of the
graphics card) it is and says that it cannot find anything to boot.
Here's the complete config for those tests:

name = 'test'
builder = 'hvm'
device_model_version = 'qemu-xen'
device_model_override = '/usr/bin/qemu-system-x86_64'
memory = 2048
# working
#pci = ['0000:01:00.1']
# not working
pci = ['0000:01:00.1','0000:01:00.0']

And here's the output from xl pci-assignable-list:


> - Can you supply your kernel config

see attachments (current Jessie kernel), pciback is a module and binds
the devices at initramfs time via /etc/modprobe.d/:

options xen-pciback
install ehci_hcd /sbin/modprobe xen-pciback; /sbin/modprobe
- --first-time --ignore-install ehci_hcd
install radeon /sbin/modprobe xen-pciback; /sbin/modprobe --first-time
- --ignore-install radeon
install snd_hda_intel /sbin/modprobe xen-pciback; /sbin/modprobe
- --first-time --ignore-install snd_hda_intel
install snd_virtuoso /sbin/modprobe xen-pciback; /sbin/modprobe
- --first-time --ignore-install snd_virtuoso

> - Any notable hardware (eg. motherboard?)

MSI Z77A-GD65, i7 3770 (non-k), Sapphire Radeon HD 7870 GHz Edition

The hardware worked 18 month with VGA passthrough, so I would exclude
it as cause, as well.

> - run `xl -vvv create` and attach the output

I attached the output from both test runs (with and w/o vga
passthrough) and the cleaned diff (there were different memory
addresses and domain ids)

> I have been using Xen 4.3 and 4.4 on Wheezy for some time now, but
> I have not yet tried with Jessie.  Off the top of my head, three
> possibilities stand out.  Could be a syntax error in your domu.cfg
> (review the latest man pages:
> http://xenbits.xen.org/docs/4.3-testing/man/xl.cfg.5.html).  I
> still build pciback into my kernels as I have never had good luck
> with late device binding even with though the xl toolstack should
> do so; is pciback compiled into the kernel and your devices hidden
> by grub, or are you relying on late binding?  There have been
> problems with larger amounts of memory.  Have you tried dropping to
> 1~2 GB of ram in your config (yes I am aware that it is a very
> small amount for Windows to run well on, maybe try it just to
> confirm possible causes)?

I dropped the allocated RAM to 2GB, but no difference.

> Send us more info.

Hopefully, the info I now provided is more helpful.


> On Sun, Dec 8, 2013 at 7:58 AM, Volker Klasen
> <reklov@xxxxxxxxxxxxxxxx>wrote:
> Hello,
> the short version: I can't get VGA passthrough working with Xen
> 4.3 and Qemu 1.7. The VM won't even display a bios screen.
> The long version: after successfully running Windows 7 64bit with
> a passthrough'd Radeon HD 7870 about 1.5 years with Xen 4.1 
> (xm/qemu-dm), I decided it was time to upgrade to Jessie's current
> Xen packages (4.3).
> Unexpectedly, I came across several issues related to switching
> from xm to xl and from qemu-dm to qemu, as well as non-functional
> VGA passthrough. I found 2 setups that at least would start the
> VM:
> 1) Using qemu-dm from Wheezy packages xen-utils-4.1 In this setup I
> can pass through all 4 PCI devices (USB controller, VGA card, HDMI
> audio and audio card), however, none is working. For the audio card
> error 10 is reported, for the graphics card error 43.
> 2) Using qemu In this setup PCI passthrough works as long as I do
> not passthrough my VGA card (the other three are working without
> problems). As soon as I passthrough the graphics card, the VM won't
> even startup at all (vnc is running but no bios is displayed, only
> black screen); the logs are empty, as well (the only line is
> "Waiting for domain ..." in /var/log/xen/xl-domain.log).
> I tried setting and unsetting the pci_* options in the domain
> config file but I had no luck. Here's my current config (left some
> unrelated things out) set up for 2) with VGA passthrough
> (01:00.0):
> # qemu device_model_version="qemu-xen" device_model_override =
> '/usr/bin/qemu-system-x86_64' # qemu-dm 
> #device_model_version="qemu-xen-traditional" #device_model_override
> = '/usr/lib/xen-4.1/bin/qemu-dm'
> builder = 'hvm' viridian = 1 vga = 'stdvga' pci_msitranslate = 0
> #pci = ['0000:00:1d.0','0000:01:00.1','0000:04:04.0'] pci =
> ['0000:00:1d.0','0000:01:00.0','0000:01:00.1','0000:04:04.0']
> Has anyone an idea what I could try?
> Thanks, Volker
>> _______________________________________________ Xen-users mailing
>> list Xen-users@xxxxxxxxxxxxx http://lists.xen.org/xen-users
> _______________________________________________ Xen-users mailing
> list Xen-users@xxxxxxxxxxxxx http://lists.xen.org/xen-users

Version: GnuPG v1.4.15 (GNU/Linux)
Comment: Using GnuPG with Icedove - http://www.enigmail.net/


Attachment: config-3.11-2-amd64.gz
Description: GNU Zip compressed data

Attachment: xlcreate.txt
Description: Text document

Attachment: xlcreatediff.txt
Description: Text document

Attachment: xlcreatevga.txt
Description: Text document

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.