[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough in Xen 4.4

Can you post the /etc/xen/guest.cfg file content? You need to make sure to use to use the following line in your guest.cfg file:
device_model_version = 'qemu-xen-traditional'
instead of:

Unfortunately there seem to be some bugs with Xen / xl / perhaps the kernel. I'm getting very inconsistent VGA passthrough results with any Xen release after 4.1.2, or even a newer kernel than the one that was released with Ubuntu 12.04.

My Nvidia Quadro 2000 works fine with Ubuntu 13.10 / Linux Mint 16 with a 3.11 kernel and Xen 4.3 using xl. But the results with both the AMD Radeon 6450 and the Radeon 7770 are very much dependent on the kernel and Xen release. xm has been the most successful way to get AMD cards passed through, but only when using Xen 4.1.2 and an old kernel - no issues whatsoever.

Recently I tried Ubuntu 14.04beta2 with Xen 4.4 and xl and it worked great with an AMD 6450, including multiple guest reboots without performance or stability issues. But later I tried the AMD 7770 with the Ubuntu 14.04 final release and Xen 4.4 and though passthrough worked at the first time, a reboot of the guest would give me a VNC screen and yellow triangle in Windows for graphics adapter, which seems to be a known problem.

Speculations are that these issues may be related to the way a particular graphics card is reset (or not) after the guest shutdown. But strangely enough old Xen releases and xm work just fine with the same hardware and guest graphics driver (in my case Windows 7 Pro with the latest stable AMD graphics driver, or the beta driver).

Long story short - I'm not surprised that Xen 4.1 with xm toolstack worked, whereas the new xl toolstack with Xen 4.4 doesn't. There have been enough reports about the VGA passthrough issues, the only thing I haven't found yet is a definite answer or solution to it.
On Thursday, April 24, 2014 9:53 PM, TheLowEndTheory <nickrv8@xxxxxxxxx> wrote:
Having updated from 4.1 to 4.4 I am now using the xl toolstack, and it seems
that there is a bug dealing with VGA passthrough. I have a Windows guest and
can get the card to show up, however it throws the error

"If you want to use this device, you will need to disable one of the other
devices on this system."

qemu's log shows

"pt_pci_read_config: [00:05:0] Error: Failed to read register with invalid
access size alignment. [Offset:0eh][Length:4]"

There seem to be plenty of instances of this around the internet, however as
far as I have found, there is no solution.

View this message in context: http://xen.1045712.n5.nabble.com/VGA-Passthrough-in-Xen-4-4-tp5722323.html
Sent from the Xen - User mailing list archive at Nabble.com.

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.