[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] ucode=-1: did anybody have success?


does anybody use Xen's ucode=-1 option successfully?
I'm trying to update the microcode before dom0 starts, since my dom0
doesn't have the xen microcode driver. I'm using a vanilla 3.12.x kernel
from kernel.org and to the best of my knowledge, the xen microcode
kernel driver didn't make it upstream yet.

So I'd like to use ucode=-1 since I don't use any initrd. The
documentation is speaking of a CPU microcode update BLOB that I need to
add to my GRUB configuration as a module. But: BLOB in which format?

Well, on my system the microcode exists in two formats:
- /lib/firmware/microcode.dat (not sure what the format is, it's
definitely not cpio based, as would be needed for ucode=scan)
- many single files in /lib/firmware/intel-ucode/

Which line in grub would be correct? I guess it isn't
  module /lib/firmware/microcode.dat
  module /lib/firmware/intel-ucode/<somefile>
by any chance?

Now the documentation of ucode goes on to talk about some file
called kernel/x86/microcode/GenuineIntel.bin. But it only talks about it
in combination with ucode=scan. A wild guess could be, that this file is
identical to microcode.dat. Another wild guess could be, that this file
is something I have to download from intel, and this is also the file I
have to use as a module in case I'm using ucode=-1 instead of ucode=-1.
Or maybe the file is taken from /lib/firmware/intel-ucode/ and is copied
to the initrd when it is updates?

So could somebody who did all the research and experimenting present his
working configuration?

I think I tried microcode.dat once, and it didn't seem to work.
I haven't tried a file from /lib/firmware/intel-ucode/ as I only have
one production system and my test system is a VM where microcode updates
are not possible.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.