[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] not enough resources

  • To: xen-users@xxxxxxxxxxxxx
  • From: Gordan Bobic <gordan@xxxxxxxxxx>
  • Date: Tue, 01 Jul 2014 08:23:18 +0100
  • Delivery-date: Tue, 01 Jul 2014 07:23:35 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

The only time I have seen the GPU not initialize due to
"not enough resources" in device manager, it was fixed
by disabling the emulated VGA device in device manager.

I have two passthrough VMs, passing a modified 780Ti
to each, and they work fine. I never tried passing
more than one GPU to a single VM.


On 2014-06-30 18:48, jacek burghardt wrote:
Was anyone able to pass two video cards ? I installed 14.2 amd drivers
and wolfenstein plays good on my HD 6450. I just ordered R7 270 for 80

 On Sat, Jun 28, 2014 at 3:46 PM, jacek burghardt
<jaceksburghardt@xxxxxxxxx> wrote:

no go for me ÂI bet there is need for more patching may be the
address issue of vga card missing,

On Sat, Jun 28, 2014 at 2:16 PM, Matthias
<matthias.kannenberg@xxxxxxxxxxxxxx> wrote:

Can you post your domU config?

I tried several things but couldn't get my domU running with vga
passthrough on upstream qemu. without vnc or splice, the domU is not
created, as you noted, but with splice, i got the same error
message. the only way i could get it running was with vnc, but in
this case and with vga=none the domU would not even get to the boot
screen and would sit idling at 2,5% cpu in xl top while my first cpu
core (exclussivly for dom0) will go to 100% constant in htop. with
vnc and stvga, i would get past the boot screen but would get the
same behaviour 2 seconds into the boot process.

So I am wondering if you do something else differently then I do
(like viridian, pci_power_management, pci_permissive,
xen_platform_pci etc).

2014-06-28 16:21 GMT+02:00 jacek burghardt

Well it is strange that it still needs vnc or spice to start. I had
disable both and xl failed to start new instance of hvm

On Sat, Jun 28, 2014 at 7:18 AM, Matthias
<matthias.kannenberg@xxxxxxxxxxxxxx> wrote:

This is great to hear because this abbility is in fact already


Thanks for the info. Will do some test runs later. :)

2014-06-28 15:12 GMT+02:00 jacek burghardt

Well i just pass my 6450 to 8.1 as a secondary video card and i can
reboot without having to reject the card first.Â
kvm just tells qemu to turnoff vga with vga=0 I think that a simple
solutions would be to add ability to pass vga=0 to qemu.

On Sat, Jun 28, 2014 at 1:49 AM, Matthias
<matthias.kannenberg@xxxxxxxxxxxxxx> wrote:

No, qemu traditional does not support spice.. this was something
introduced to qemu upstream.

But great to heare that both this now works for you and that the
4GB bug is finally fixed in xen unstable!

Would you mind sharing your domU config? I never got primary
passthrough running with qemu upstream and had to always fall back
to qemu-traditional. Iirc, you were one of the guys who used nvidia
cards with the extra patches, weren't you? Can you successfully
reboot your domU without rebooting the dom0 (basically my last big
issue with vga passthrough with AMD).


2014-06-28 7:57 GMT+02:00 jacek burghardt

I added more memory and I was abel to get 8gb of ramÂ

On Fri, Jun 27, 2014 at 5:35 PM, jacek burghardt
<jaceksburghardt@xxxxxxxxx> wrote:

I just compiled xen-git 4.5 and it works.Â

On Fri, Jun 27, 2014 at 1:51 PM, jacek burghardt
<jaceksburghardt@xxxxxxxxx> wrote:

I run xen 4.4 on arch linux with qemu upstream. I tried to use
qemu-traditional with direct passing of video card but it sits at 0
log show something about no cpu. I guess qemu traditional does not
support spice ?Â

On Fri, Jun 27, 2014 at 1:14 PM, Austin S Hemmelgarn
<ahferroin7@xxxxxxxxx> wrote:

On 2014-06-27 14:21, jacek burghardt wrote:
Well I can bootup with 3.5GB

On Fri, Jun 27, 2014 at 11:11 AM, Austin S Hemmelgarn

<ahferroin7@xxxxxxxxx <mailto:ahferroin7@xxxxxxxxx>> wrote:

  On 2014-06-27 12:43, jacek burghardt wrote:
  > So my xen desktop has only 8gb of ram. I had assigned 2gb
of ram
  to dom0
  > and 3gb to win8 with assigned 6450. I was trying to
assign 4GB of ram
  > and then HD 6450 has an error with 4gb not enough
resource. with 3gb
  > everything works great.
  > Is this bug in xen or I need more ram?
  > _______________________________________________
  > Xen-users mailing list
  > Xen-users@xxxxxxxxxxxxx <mailto:Xen-users@xxxxxxxxxxxxx>

  > http://lists.xen.org/xen-users [2]
  It's probably an issue with how Windows lays out it's

The only reason I'm thinking it's a issue in Windows is because 4GB
the per-process (and per-driver, and also on the really basic
system) memory limit, and there are known issues with some drivers
you approach this limit. ÂMy guess is that there is some amount of
memory that the driver is mapping from the card, and it is also
to map space equal to the physical RAM size for the CPU, which in
adds up to more than 4G.

 Xen-users mailing list
 http://lists.xen.org/xen-users [2]

[2] http://lists.xen.org/xen-users

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.