[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xl vifscript (apparently) not called at all

On Thu, 2014-09-04 at 16:44 +0200, Renato Ramonda wrote:
> Hi all,
> I'm using Xen 4.1.4-3+deb7u1 on a Debian Wheezy 7.1
> We use Openvswitch and vlan tags on all the domU vifs, so we have a
> "vif-openvswitch" script in /etc/xen/scripts, configured
> in /etc/xen/xl.conf as
> vifscript="/etc/xen/scripts/vif-openvswitch"
> Until recently everything was working fine and dandy: the domU vif
> configuration looks like this
> vif = [ 'mac=00:02:c0:a8:ce:0b,bridge=xenbr0.606' ]
> and the vif was correctly tagged in openvswitch and brought up.
> Now it's not working correctly anymore (I suspect after a dist-upgrade,
> but can't confirm it 100%): when creating a domU instance (xl create
> vm.cfg) the vm starts, and a new vifXX.Y is correctly created at dom0
> level, BUT:
> 1 - The new vif is DOWN
> 2 - The new vif is not added to the xenbr0 bridge as it should
> 3 - The new vif is not tagged (obviously, since it's not in ovs at all)
> I have a maintenance script to check that all running domains have their
> expected vlan tags (done checking the "ovs-vsctl show" output against
> their config file) and when it creates the port in ovs, and I bring it
> up with "ip link set up" it DOES work right away.
> I tried to track down what's wrong for a while but I'm stuck: I even
> tried to put a simple "touch /tmp/tempfile" at the top of the
> vif-openvswitch script, and it looks like (apparently) xl is not calling
> it at all. No sign that the script is ever executed can be found.
> Does someone have some useful pointer as to where to go dig further?
> Web searches were pretty inconclusive, and a strace on xl only shows me
> that the script path IS apparently written on a control socket, but I
> don't know where to look for more.
> Thanks in advance for any help or pointers,

IIRC In Xen 4.1 the vif script are called via udev, so you might want to
check that all is ok under /etc/udev/rules.d.

Perhaps cranking up the udev loglevel might give some other clue?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.