[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Balloon driver set up failure [SOLVED]

On 25/09/14 19:59, Ian Campbell wrote:
> On Thu, 2014-09-25 at 18:45 +0530, Charles wrote:
>>> Did you mount xenfs on /proc/xen?
>> No.  I added it to fstab and rebooted.  Still no /proc/xen/balloon (only
>> capabilities, privcmd and xenbus).
> Ah, that's right I'd forgotten -- with modern pvops kernels this has
> moved under /sys somewhere. /sys/devices/system/xen_memory/ perhaps?


> Note that even if CONFIG_XEN_BALLOON is disabled and the control node is
> not present the balloon core is still active and available via the host
> interfaces, the config option only controls the guest admin visible
> interface.
>>> It looks like the balloon core is there and running (you have ~128M
>>> free, less some normal overheads, which is expected). You haven't asked
>>> the balloon driver to change that (e.g. with xl mem-set) so it won't
>>> have done anything.
>> The total memory is ~128M, not the free.
> Ballooning is weird in that way: it really changes the apparent total
> memory, not the free memory.
> Have you actually tried decreasing/increasing the memory with xl
> mem-set? What happens?

I had not.  Tried it now.  Setting 200 resulted in 182 in the DomU.

So the balloon driver is working; the defect was in my understanding of
how to test it.

Thank you Ian (and Wei) for guidance :-)



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.