[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen 4.5-unstable, oxenstored cannot start (centos 7, kernel 3.17.0)

On Fri, 2014-10-10 at 17:09 +0200, Olaf Hering wrote:
> On Fri, Oct 10, Olaf Hering wrote:
> > Up to now I have not checked how systemd support works in real life.
> > Looks like systemd has trouble to decide if sysv or service files should
> > be used. Or the OP has to enable all service files manually.
> So I just tried it, and the result is:
> root@optiplex:~ # systemctl start xencommons.service
> <wait wait wait>
> ps fax on another terminal shows:
>  2240 ?        Ss     0:00 /bin/bash /etc/init.d/xencommons start
>  2332 ?        S      0:00  \_ sleep 1
> I had expected that it would run xencommons.service. But no such thingg
> exists. So I tried "systemctl enable xenstored.service" and rebooted.
> Still no joy: "systemctl status xenstored.service" says
> ConditionVirtualization=xen was not met.
> systemd-detect-virt says none, even if /proc/xen/capabilities contains
> "control_d". So the fun stops right here for me, have to let someone fix
> that up first.
> I assume if systemd-detect-virt is similar broken for the OP the service
> files will not start. It looks like "systemctl enable
> xen-qemu-dom0-disk-backend.service" should recursively enable (or at
> least start during boot) the dependencies.

I think you probably need to take this up with Luis who implemented all
this systemd stuff. I suppose he had it working...


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.