[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XENBUS timeout connecting to device (Hard disks not detected)

On Tue, 2014-12-30 at 08:58 -0500, Philippe-A. Lemelin wrote:
> Good Morning List,
> I'm currently trying to install a CentOS DomU

What is your dom0? Also CentOS? If so which Xen and libvirt are you
using (built yourself, from packages on the net, etc)?

>  and I am facing an issue I 
> never experienced before. None of my hard disks are detected. I've now 
> tried with a single HDD or with many as I usually do and each time, I'm 
> faced with the same result. I tried with a CenOS 5 and 6 DomU with the 
> same end result, the installer is not seeing any valid devices on which 
> to install.
> Here is the command i'm using when launching the installation:
> virt-install --vnc --bridge=xenbr0 -p --name=test --ram=2000 --vcpus=2 
> --disk /images/disk1.img,format=raw --disk /images/disk2.img,format=raw 
> --disk /images/disk3.img,format=raw --disk /images/disk4.img,format=raw 
> --disk /images/disk5.img,format=raw 
> --location=http://mirror.centos.org/centos/5/os/x86_64
> When looking at the installer log I see the following ( I confirmed that 
> the 5 devices that timeout are indeed the xvda, xvdb... disks):
> <6>XENBUS: Device with no driver: device/vbd/51712
> <6>XENBUS: Device with no driver: device/vbd/51728
> <6>XENBUS: Device with no driver: device/vbd/51744
> <6>XENBUS: Device with no driver: device/vbd/51760
> <6>XENBUS: Device with no driver: device/vbd/51776
> <6>XENBUS: Device with no driver: device/vif/0
> <6>XENBUS: Device with no driver: device/console/0
> ...
> <4>XENBUS: Waiting for devices to initialise: 295s...290s... ...
> ...
> <4>XENBUS: Timeout connecting to device: device/vbd/51712 (local state 
> 3, remote state 1)
> <4>XENBUS: Timeout connecting to device: device/vbd/51728 (local state 
> 3, remote state 1)
> <4>XENBUS: Timeout connecting to device: device/vbd/51744 (local state 
> 3, remote state 1)
> <4>XENBUS: Timeout connecting to device: device/vbd/51760 (local state 
> 3, remote state 1)
> <4>XENBUS: Timeout connecting to device: device/vbd/51776 (local state 
> 3, remote state 1)
> Once the installation fails, If I connect with Virt-Manager, I can see 
> that my machines has 5 disks attached. I do not understand why it is 
> timing out like that.
> I'm looking for any debugging tips or pointers on helping me to resolve 
> this rather strange issue.

Wild stab in the dark: Is the backend driver present in dom0? Either the
kernel module loaded or the appropriate backend provider (qemu perhaps)
installed and getting launched?

The output of "xenstore-ls -fp" while the guest is running would contain
some clues as to which backend is expected, which might suggest a next

There are also various logs under /var/log/xen and presumably some
libvirt logs somewhere which would be worth having a look at.

Do you know which toolstack libvirt is talking to, either xend or libxl.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.