[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] vga passthrough with amd radeon r9 285

  • To: xen-users@xxxxxxxxxxxxx
  • From: Brian Paterni <bpaterni@xxxxxxxxx>
  • Date: Tue, 03 Feb 2015 19:23:12 -0600
  • Delivery-date: Wed, 04 Feb 2015 01:23:58 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

One more thing I tried:

I do have an older radeon hd 4850 running as the primary gpu for
another, non-xen system. This device does have a sysfs interface for
reset at


So I figured I would swap out the secondary r9 285 with the 4850. Now
when I attempt to create a windows domu with gfx_passthru=1, there is no
longer any complaint that 'the kernel doesn't support reset from sysfs'.
Unfortunately though, the 4850 is still not getting passed through:

    libxl: error:
libxl_exec.c:227:libxl__xenstore_child_wait_deprecated: Device Model not
    libxl: error: libxl_pci.c:879:qemu_pci_add_xenstore: qemu refused to
add device: 0000:06:00.0,msitranslate=0,power_mgmt=0
    libxl: error: libxl_create.c:1413:domcreate_attach_pci:
libxl_device_pci_add failed: -3

Maybe there is something else at work here preventing vga passthrough?...

I've attached verbose debug output of the xl create attempt with the
radeon hd 4850.

Also attached should be a /var/log/xen/qemu-dm-windows7.log. Looking at
that, there seem to be several problems in creating the windows7 domu,
but I'm not all that certain on how to resolve them.

Attachment: xlcreate-domu-w7-4850
Description: Text document

Attachment: qemu-dm-windows7.log
Description: Text Data

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.