[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] shared lib path errors

  • To: xen-users@xxxxxxxxxxxxx
  • From: David Van Arnem <dvanarnem@xxxxxxxxx>
  • Date: Fri, 20 Feb 2015 11:53:25 -0700
  • Delivery-date: Fri, 20 Feb 2015 18:53:34 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Hi Wayne,

It looks like you have not booted into a kernel with Xen, so although XL is installed on your system, there is no Xen for it to communicate with.  When you reboot, you should see kernel options on your Grub screen with Xen enabled, and you can boot into one of those and xl list should work.

If you don't see Xen enabled kernels on your Grub list, you'll need to update your Grub configuration, which I think on Ubuntu is done with update-grub.


On 02/20/2015 11:29 AM, Wayne Mills wrote:
Thanks David.  That fix all my ".so not found" issues.   I have now encountered a new error (see below).  I'm new to the mailing lists so please let me know if I should start a different thread.  I didn't spot this libxc error in the archives:

# xl list
xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error
libxl: error: libxl.c:109:libxl_ctx_alloc: cannot open libxc handle: No such file or directory
cannot init xl context


On Fri, Feb 20, 2015 at 1:01 PM, David A. Van Arnem <dvanarnem@xxxxxxxxx> wrote:
On 02/20/2015 10:44 AM, Wayne Mills wrote:

As part of a dev activity, I built Xen 4.5.0 from source and installed it successfully on my Ubuntu 14.04 server, However I am getting this error when running "xl list":

xl: error while loading shared libraries: libxlutil.so.4.3: cannot open shared object file: No such file or directory

Based on some archived threads, I verified the following.
--> This soft link & file exist in /usr/local/lib: libxlutil.so.4.3 -> libxlutil.so.4.3.0
--> /etc/ld.so.conf has this line: "include /etc/ld.so.conf.d/*.conf"
--> /etc/ld.so.conf.d/libc.conf has this content:
line 1: # libc default configuration
line 2: /usr/local/lib

Based on archived threads, xl should be searching /usr/local/lib based on the above.  But it is obviously not.  Meanwhile I tried linking the /usr/local/lib copy to /usr/lib.  That worked (but now it's complaining similarly about not finding libxenlight).  Not sure it matters but one final detail: echo $LD_LIBRARY_PATH from my shell shows nothing.

Are there any solutions recommended other than putting soft links in /usr/lib?


I don't know if this is the best solution, but in the past when I've encountered this error I used ldconfig and pointed to the location where my Xen libraries were installed (and then reboot).  So for you, probably:

ldconfig /usr/local/lib

Xen-users mailing list

Xen-users mailing list

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.