[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] domU with two eth but only one is active

  • To: xen-users@xxxxxxxxxxxxx
  • From: SZABO Zsolt <szazs@xxxxxxxxx>
  • Date: Sat, 18 Jul 2015 11:07:08 +0200 (CEST)
  • Delivery-date: Sat, 18 Jul 2015 09:08:20 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

On Sat, 18 Jul 2015, Ian Campbell wrote:

On Sat, 2015-07-18 at 00:56 +0200, SZABO Zsolt wrote:
What can be the problem?

Nothing in the configuration you describe stands out to me as being

Do you have eth1 configured within the guest? What does the in-guest
config and state look like?

Originally, both eth0 and eth1 in domU was configured by dhcp
but now it only works for eth0, thus, I configure eth1 static:

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet static

I have also checked dmesg in the guest:
# dmesg |grep -i net
[    0.033297] Initializing cgroup subsys net_cls
[    0.033330] Initializing cgroup subsys net_prio
[    0.118117] NET: Registered protocol family 16
[    0.208776] NET: Registered protocol family 2
[    0.212141] NET: Registered protocol family 1
[    0.301223] audit: initializing netlink subsys (disabled)
[    1.376536] NET: Registered protocol family 10
[    1.377181] NET: Registered protocol family 17
[    1.472973] xen_netfront: Initialising Xen virtual ethernet driver
[    1.601085] xen_netfront: can't alloc rx grant refs
[    1.601105] net eth1: only created 16 queues
[    9.095908] FS-Cache: Netfs 'nfs' registered for caching

Did you upgrade the guest too or just dom0?

I have also upgraded the guest to jessie...

Some versions of xl were fussy about spaces within the vif descriptions
(like the one before the "bridge=" in yours). Since your eth0 works I
doubt this is the issue you are seeing, but I suppose it is worth
removing them just in case.

I have tried, nothing improved. :-(

Ok, I have another linux domU but with wheezy. Originally, only eth0 was configured, but now I have also tried to add eth1 similarly as to
the jessie domU and it works...

The dmesg of this domU is shorter:
# dmesg |grep net
[    0.004000] Initializing cgroup subsys net_cls
[    0.004000] Initializing cgroup subsys net_prio
[ 0.134434] microcode: Microcode Update Driver: v2.00 <tigran@xxxxxxxxxxxxxxxxxxxx>, Peter Oruba
[    0.134838] audit: initializing netlink subsys (disabled)
[    1.340978] xen_netfront: Initialising Xen virtual ethernet driver

Maybe the jessie upgrade missed some feature of the later upgraded dom0?
Or it is about some kind of other conflict...?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.